XFX R9 280X low hashrate

edited December 2013 in Hardware support

I recently got myself an XFX R9 280X card solely for mining litecoins. the system it is connected to is a core 2 duo E8400 , 4GB Ram, 550Watt psu. Windows 7 and bfgminer 3.8.0
the config looks like this.
bfgminer --scrypt  -o http://ltc-eu.give-me-coins.com:3333 -u user -p pass --thread-concurrency 24000 -w 256 --gpu-engine 1100 --gpu-memclock 1500 --gpu-powertune 20 --gpu-fan 100 --auto-gpu -g 1 -I 18

I get around 500kH/s with this, but I should be getting > 700 kH/s.

I have tried setting thread concurrency to 8192, I have also tried g 2 and I 13 as most do, no change in hashrate, it seems to cap at around 500 no matter what I do. setting I above 18 does nothing.


  • I'm using the AMD Catalyst 13.11 beta driver v9.5

  • do you have the standard version (R9280xTDFD) or the black edition (R9280xTDBD) ? The standard has a much lower score according to litecoin hardware wiki.

  • standard, I have heard that I need a newer bios for it to reach the expected hashrate, version 40 to be exact. but I can't find a bios for this gpu.

  • edited December 2013

    The latest BIOS I could find was 15.039 indeed...

    Two things regarding the hashrate:
    1) Is the XFX the 2nd card and your forgot to mention your main card, or do you use it for your desktop/games while mining ?
    2) I attached you an image...please perform all the steps mentioned, except the last part about undervolting.
    That thing got resized and ended up being pretty small -_-
    Here you go.

  • it's the only gpu in the computer, and until I get a dedicated computer for mining, this computer's other tasks are suspended. no gaming.

    I shall try tweaking the settings according to the image later after work, thank you :)

  • edited December 2013

    No problem.

    I am testing with 3 XFX 280x Black Edition myself atm (just got the rig running yesterday, with a shitload of annoying bugs in xubuntu 13.10).
    Best I've come across so far is 643 KH/s with parameters as followed:
    --auto-fan --gpu-fan 50-100 -I 20 -w 128 --thread-concurrency 28672 --gpu-engine 1148 --gpu-memclock 1497

    I am a little frustrated atm for I've already been testing stuff for several hours now and still not getting anywhere above those ~640...

    PS: I read "I shall try tweaking the settings later at work" :D

  • edited December 2013

    Alright, this was a good day: Very stable ~717 KH/s at last.

    Don't know if you can apply my settings 1:1 for you are not using Black Edition cards, but feel free to try:
    Link to config
    (you can feed this to cgminer via 'cgminer --config PATH/TO/CONFIG')


  • I tried most combinations of the settings, my card won't go over 550 whatever I do. I'll have to flash in another bios, probably the one from msi. if you have any reason why I shouldn't attempt that, please tell me.

  • edited December 2013

    Did you try the config ? No harm in wasting another 5 minutes before flashing the vBIOS ;)

    And regarding to that: Does your card have a vBIOS switch ?
    At least my XFX has none, which is why I will send them back. No undervolting in Linux without the massive threat of bricking the card because I can't reset it to the other vBIOS.

    You clearly void any warranties when flashing, so if Murphy's Law kicks in you will end up as the owner of a 300 € paperweight - therefore I think a vBIOS switch is a must have before considering to flash :)

  • I flashed the card. I get around 660kH/s now. but I'm hardly getting any accepts now. I'm not getting any rejects. the give-me-coins site is not recognizing my work. says 0kH/s....

  • image

    this is getting real frustrating. nothing is happening, no accepted and no rejects, nothing.

  • Try another server (or pool) and see what happens.

  • edited December 2013


    I've got my R280X three gays ago (a Gigabyte GV-R928XOC-3GD Rev. 2.0) and had similar difficulties to reach decent hashrates. That card got 1100 MHz engine and 1500 MHz memory frequencies out of box.

    Looking on forums for good settings, I've followed the advise to use a engine at about 1000 and thread-concurrency 8191 (not 8192) together with power tune -20:
    -w 256 -v 1 -I 13 -g 2  --lookup-gap 2 --gpu-powertune -20 --gpu-memclock 1500 --gpu-engine 1029  --thread-concurrency 8191

    There is a small spot for the optimum engine frequency for MY card between 1025 and 1030

    Now my hashrate is about 720 kH/s

  • hi, i have the XFX 280X DD non black with 40 bios, i am still not getting beyond 600 MH, i am at 1040 1499.

    if u want i can provide the bios file.

    which MSI bios are u using?

  • I had to flash the original bios back, I've tried with msi bios version 40, and sapphire bios version 41. both seem to work fine, but when I put any load on the graphics cards, the screen goes black.
    thwe problem I had before with the lack of accepts was that I had set the thread concurrency to 2048, that produced a good hashrate, but the card couldn't find anything.

    which bios are you using, from which vendor?

  • i bought my XFX cards (6 of them) from amazon 10 days ago they came with bios 015.040.

    i am currently getting 670 kH using 1029 1500 setting with 8191 concurrency (i am still tweaking)

    if u want give me a location to upload the bios into

  • don't have any uploadable areas. you could send it by mail if you want :) peter.t.dahlgren@gmail.com
    it would have been nice if xfx could have these new bioses on their website

  • edited December 2013

    did u get my email?

  • Got it :) thank you, I sent a reply. maybe it didn't get through. I'll try flashing this into my card tomorrow after work. I'll post the results here afterwards

  • Thank you! I clearly get a better hashrate with the bios you sent me. I get around 570 now, will have to wait and see what the average on the site will show.

    I'm using the same settings that Bernd suggested.

    if you've narrowed down a setting that works for you madnod, I'd like to test it.

  • I have the xfx 280x black edition and I'm having the same issues.  I've tried pretty much all of the configs listed here, and my hash rates  vary from 295kh/s to 525kh/s as indicated on the dashboard here with cgminer version 3.7.0 but normally sticks the longest around 380kh/s to 425kh/s   When I try cgminer version 3.7.2 cgminer shows a hash rate of around 560kh/s to 600kh/s but only indicates about 250kh/s here on the dashboard.   I don't have any errors popping up just a low hash rate.  i'm using the AMD Catalyst 13.11 beta driver v9.5 as mentioned and when I used the newer drivers I had worse hash rates on cgminer version 3.7.0,  did not try it on the newer version of cgminer though.  

    If I try to go above I 13 in 3.7.0 cgminer fails,  in 3.7.2 the best hash rate comes with the Intensity at 14 and drops off if I go any higher.

    I looked at the bios version on my card and it's the latest one of 40.0.0.....1

    I'm getting really frustrated here as I only bought this card to mine with, and I was expecting from the hardware comparisons to see around 700 kh/s.

    The rest of the system specs are as follows

    AMD FX8350
    32GB ram
    Win 7 64bit
    256GB SSD  C: Drive
    6TB hardware Raid 5 for Storage Drive
    Asus Crosshair V MB

  • if you get a lower hashrate on the dashboard than in cgminer, you might want to increase the thread concurrency. 

  • tl;dr

    If it runs at memclock 1550 - change it to 1500.

  • O.K.  I have tried changing the thread concurrency around with not much luck at all,  still have the almost 1/2 the hash rate between cgminer and the dashboard.


    Thanks for the tip on the memclock,  I changed it to 1500 as you suggested and it did increase my cgminer shown hash rate to a fairly steady 598-603kh/s,  but I still rarely see above 350kh/s on the dashboard here on give_me_coins, or on the android app for here. 

    Now on my Laptop that has a Nvida 675m that I use cudaminer on most of the time the dashboard shows withing about 5% of cudaminer's hash rate so it is atleast reporting the laptop correctly.

    Again I have watched cgminer and have no errors showing up.  My temps are good on the card staying around 66°c unless I go with a higher thread concurrency then it will get to around 71°c but no increase in hash rate but a drop in hash rate if I go above 12288, other then that hash rate stays the same between 8192 and 12288.


  • Well I think I'm finally getting closer.

    I've been tweaking settings using Version 3.7.0 of cgminer and I'm having better luck with that on getting my hash rate within cgminer and here on the dashboard closer together.   It still jumps around a lot but for the most part it stays in the 500+kh/s range with about 25% going into the 600+kh/s and a few into the 700+kh/s on the dashboard.  cgminer shows a fairly consistent high 500s to low 600s kh/s.

    I turned Verbose on for awhile to see more of the details while I was tweaking the setting and I noticed with 3.7.2 I had a high rate of "Share above Target" messages, where as in 3.7.0 I don't have near as many.  So I'm thinking this had alot to do with my big difference in cgminer's hash rate vs GMC's dashboard hash rate.

    I am still thinking about getting a set of Sapphire Dual-X R9 280X cards though to put in my desktop to replace the XFX one since the XFX card doesn't seem to live up to the 280x's expectations on performance for mining.  I'll just put the XFX card in my kids computer and run cgminer in a low priority mode so that when they are playing games hopefully it doesn't impact the performance of their gaming much, plus it should be a nice upgrade for them since they only have a Nvidia GTX 460.

    If setting cgminer to low priority doesn't work is there a setting in cgminer that I can pass to make it lower it's load on the card when the kids run a program that needs the power of the R9 280x card and not just the iGPU? Their computer does have Lucid Logix MVP installed so most of the time it just uses the iGPU from the I5 Intel CPU until the more powerful dedicated card is needed.

    Thanks in advance,


  • Guys this is what gets me above 700kh/s. Windows 7, cgminer 3.7.0, XFX Black Edition... If you make any optimisations let me know. 

    "pools" : [
    "user" : "wobwob.xxx",
    "pass" : "sdsd"
    "intensity" : "13",
    "vectors" : "1",
    "worksize" : "256",
    "kernel" : "scrypt",
    "lookup-gap" : "2",
    "thread-concurrency" : "11200",
    "shaders" : "2048",
    "gpu-engine" : "1036",
    "gpu-fan" : "85",
    "gpu-memclock" : "1500",
    "gpu-memdiff" : "0",
    "gpu-powertune" : "0",
    "gpu-vddc" : "0.000",
    "temp-cutoff" : "95",
    "temp-overheat" : "85",
    "temp-target" : "80",
    "api-mcast-port" : "4028",
    "api-port" : "4028",
    "auto-fan" : true,
    "expiry" : "120",
    "gpu-dyninterval" : "7",
    "gpu-platform" : "0",
    "gpu-threads" : "2",
    "hotplug" : "5",
    "log" : "5",
    "no-pool-disable" : true,
    "queue" : "1",
    "scan-time" : "60",
    "scrypt" : true,
    "temp-hysteresis" : "3",
    "shares" : "0",
    "kernel-path" : "/usr/local/bin"

    Try it out. :)

  • my 6 XFX R9 280X (non black) are hashing now between 660-710 (the 710 is in a separate system)

    clock are at are 1040 core, 1499 memory thread concurrency 8191 all under voltaded at 1075 in VBE. bios is version 40.
  • Hi 

    I am completely new at mining, so I'd like to ask a stupid question:
    If my cgminer shows 610 kh/s - 620 kh/s, but in the pool dashboard i see my hashrate 740 kh/s, am I ok? It's been 30 mins since I started mining. My card is R9 280X from XFX. I followed the guide at www.cryptobadger.com/build-your-own-litecoin-mining-rig/, so my .bat file looks like this:
    timeout /t 30
    cgminer --scrypt -I 19 --thread-concurrency 21712 -o stratum+tcp://eu.multipool.us:7777 -u ????.1 -p x
  • Maybe I can clarify that question for you. the hashrate you see on the dashboard is not the actual hashrate of your card, but a calculated number depending on the number of shares you've submitted during a given time frame. the hashrate you see in cgminer is the actual hashrate, but since it's more or less luck whether you find a share to submit or not generates a rather random hashrate on the dashboard.

    let me know if I'm off on this.

  • Thank you for explanation! 

    It looks like I'm not a lucky person: since I posted my last question, I'vevnever seen hashrates in the pool to be higher than hashrates  in cgminer :). I have to take this in account when I calculate profitability, in terms of buying hardware.
  • Try this config:

    "pools" : [
    "url" : "stratum+tcp://xxx",
    "user" : "xxx",
    "pass" : "xxx"


    "api-listen" : true,
    "intensity" : "13",
    "worksize" : "512",
    "kernel" : "scrypt",
    "lookup-gap" : "2",
    "gpu-engine" : "1060",
    "gpu-memclock" : "1500",
    "thread-concurrency" : "8193",
    "temp-cutoff" : "95",
    "temp-overheat" : "85",
    "temp-target" : "65",
    "gpu-fan" : "0-85",
    "auto-fan" : true,
    "gpu-threads" : "2",
    "no-pool-disable" : true,
    "scrypt" : true,
    "shares" : "0"

    And download saphire TRIXXX or Afterburner, and set this values
    Engine : 1060
    Memclock : 1500
    VDDC : 1.106 - IT gives You lover temp and less power compsumption (up to 100w - i've tested it)

    This config gives me 730 - 735 kh/s! and temps about 73deg in closed case

  •  -I 19 -g 2 --thread-concurrency 24000 --worksize 256 --gpu-engine 1053 --gpu-memclock 1500 --scan-time 1 --gpu-powertune 20 --queue 0 --lookup-gap 2

    This will get you 700Kh/sec
  • Hey guys,

    I recently purchased 3 brand new XFX R9 280x GC to build a new rig ( I was running 3 Hd 7970 at 650khs/s) but I've been trying to figure how to properly tune mycards in order for me to get a decent hashing speed. Right now I cant barely stay 500 khs/s. I've been trying to fix the issue for the past couple of days without any luck. I've noticed that my GCs have th lastest bios and maybe thats an issue, these are the settings Im currently running


    ./cgminer --scrypt -o stratum+tcp://doge.cryptotroll.com:3336 -u xxxxx.xxxxx -p xxxxxx -I 13 -g 2 -w 256 --thread-concurrency 8192 --gpu-engine 1040 --gpu-memclock 1500 --gpu-powertune 20


    Im getting something around 500 khs/s but i know this GC are rated up to 750 khs/s so its getting a little frustrating not able to make them work how they suppose to. I read that XFX GC do not perform as well as their counterparts like Sapphire or Gigabyte but I dont know how much this is truth.


    I would really appreciated if somebody helps me to figure this out so at the very least can make the money I invested on this cards back, Ill donate some coins if anybody gives me a killer setting.



  • Try changing to -g 1  and then bumping --thread-concurrency up to 22400.  You should then be able to inch --intensity up to 18 or more.

Sign In or Register to comment.