CGMINER - hardware errors - R9 290 - Sapphire - Battlefield 4 Edition

edited December 2013 in Miner Configs
Cannot get more than 138Kh/s on my Sapphire R9 290 Battlefield 4 Edition without hardware errors.

-Sapphire R9 290 Battlefield 4 Edition SKU: 21227-00-50G
-Video Bios : L41 when you flash it v015. 
- shows using v.3.7.2 of CGMiner to use a -I 20 and a -g 2 -

It also says to run at 1.250 voltage which I do not understand? - - I address overclocking below

Command Lines:
--Have Tried at -I 20 - all I get is hardware errors and no accepts
--If I run at more than an intensity 11 I get hardware errors
--If I run at an intensity 12 i get 250KH/s with a few hardware errors
-Have run with the Video Card not over clocked and have run with it over clocked.  Generally I run with the AMD Catalyst Overrdive GPU at 13% over, memory at 12% over, and power at 20% over.

cgminer.exe --scrypt -o stratum+tcp:// -u account.1 -p password -I 11
cgminer --scrypt -o -u account.2 -p password --shaders 2560 --intensity 10 --worksize 128 -g 2
cgminer --scrypt -o -u account.2 -p password
cgminer --scrypt -o -u account.2 -p password --shaders 2560 --intensity 10
cgminer --scrypt -o -u account.2 -p password --shaders 2560 --intensity 10 --gpu-engine 947 --gpu-memclock 1250
cgminer --scrypt -o -u account.2 -p password --shaders 2560 --intensity 10 --gpu-engine 1070 --gpu-memclock 1380
cgminer --scrypt -o -u account.2 -p password --shaders 2560 --intensity 10 --gpu-engine 1070 --gpu-memclock 1380 --temp-target 94 --auto-fan
cgminer --scrypt -o -u account.2 -p password --shaders 2560 --intensity 10 --gpu-engine 1070 --gpu-memclock 1380 --temp-target 94 --auto-fan --worksize 128 -g 1
cgminer --scrypt -o -u account.2 -p password --shaders 2560 --intensity 10 --gpu-engine 1070 --gpu-memclock 1380 --temp-target 95 --auto-fan --worksize 128 -g 2


  • Have tried all these command lines none of these have made any difference really a couple have taken it from 65 -> 125kH/s.

  • Finally got it to work at 564Kh/s which I think is low.  As well the FAN is maxed at 85% speed

    cgminer.exe --scrypt -I 13 -g 2 -w 256 --thread-concurrency 8192 --auto-fan --auto-gpu --gpu-engine 1070 --gpu-memclock 1400

    this only took 12 hours still not quite done.
  • Im 99% sure its your conccurency rate. Ive been doing some testing with various 290X and 280x cards over the past few days. Ive found the 280x cards less prone to issues and far less noise / heat but if you already have the 290 for gaming then sure,m use it ....

    -l 13 ..... i'd only use a nuber this low if your working lots on the system, ive used -19 with light work and change to -20 overnight to get upto around 800K/H with a standard clocked 290x.

    -w 256 .... i've actually only tried the 290x on 512, but try both.

    -thread concurrency 8192........ this is where i think your going wrong, ill check my exact settings tomorrow as im away from my rig but ive got the 290x card on something like 27200, and the 280x at 24200. I've noticed that getting these wrong results in an 80% HW rate.

    hope this helps.

  • I finally figured this out.  Going to post all my results to help everyone out.

    This guy got me 95% of the way.  His solution works out of the box, although by default set the fan speed to auto.

    This site says you can overclock the memory on a R9 290 by 14% so that equals 1425Mhz

    This site after reading the first two has alot of information and context read all the way through it.

    Just a FYI for below memory max on R9 290 = 1425 I think if anyone finds a faster rate please add to this thread.  The max GPU is 1079.

    With the config posted below, I ran each of these tests for exactly 2 mins of they all started between 45-50 degrees celcius.
    GPU Mhz/Memory Mhz

    947/1500 = 840kH/s = unstable got fuzzy horizontal lines across the screen
    1079/1250 = 705kH/s
    1000/1400 = 701kH/s
    947/1412 = 769/kH/s
    975/1412 = 735kH/s
    1000/1412 = unstable ran it multiple times never got a stable run. 1000Mhz is the 290X clock speed thought it would be work a try.

    947/1425 = 789kH/s and 787kH/s ran it twice.  This is the one you want.  

    If anyone else finds that we can run the memory faster please update us all.  My config file below in the next reply.

  • {
    "pools" : [
    "url" : "stratum+tcp://",
    "user" : "usernameofworker.1",
    "pass" : "password"

    "intensity" : "20",
    "vectors" : "1",
    "worksize" : "256",
    "lookup-gap" : "2",
    "thread-concurrency" : "32765",
    "gpu-engine" : "947",
    "auto-fan" : true,
    "gpu-memclock" : "1425",
    "gpu-powertune" : "20",
    "temp-cutoff" : "96",
    "temp-overheat" : "95",
    "temp-target" : "93",

    "api-port" : "4028",
    "expiry" : "120",
    "failover-only" : true,
    "gpu-threads" : "1",

    "log" : "5",
    "queue" : "1",
    "scan-time" : "60",
    "temp-hysteresis" : "3",

    "scrypt" : true,
    "kernel" : "scrypt",
    "kernel-path" : "/usr/local/bin"
  • I dont set my 290s fan setting to default. I run it at 70%, 900core/1350 mem. The thing with the 290s is that it throttles like crazy if you leave it in default. I am getting right about 800kh/s with that.

    worksize is 512
    thread concurrency is 32765
    intensity 20
    gpu threads 1

    The higher core you go the more it throttles, if you want to run it at stock clocks then you will need to set fan really high and not have it on auto. I have tried 1000 core/1400 mem and I have gotten 870 kh/s but the fan is way too loud and it gets really really hot.
  • I have MSI R9 290 and having problem with settings in this thread resulting in error:-

    Maximum buffer memory support says 536870912. Your scrypt settings come to 2147287040. Decrease TC or increase LG.  

    Only way to get cgminer to run is to set thread concurrency lower to 8192. Get good hash rate 700kH/s but only reported at ~7 in dashboard.

    Any idea anyone - hope ok posting in this thread.

  • dast - run the following commands before running cgminer in a command prompt.


    hope this helps
  • edited December 2013

    You have most likely issues with heat, unless you are using aftermarket cooling solution (modified Accelero or Prolimatech is highly recommanded).

    Thing is, these GPUs run at max power only when they are cooled enough, otherwise when they hit certain temperature, they lower their clocks (thus efficiency).

    You see HW errors cause GPU is overheating and probably reached bottom of frequency. GPU must be 100% stable to produce good results (means enough cooling and juice).

    Unfortunately AMD made really bad decision with using just regular stock cooling that is far from enough. Those GPUs have usually even pretty decent OC potential, but only when cooled.

    You should have "thread concurrency" set to number of shader engines multiplied by architecture used. In theory 10240, but in practice try 2560 first. And see what works. I think those HW errors are due heat, not settings..

  • I'm getting avg 900KH/s with 1040/1488, TC 22400 (target temp 87, auto fan 65-90) running 3 cards... Ran solid for over 12 hours! Got no hardware errors, but did get some rejects (1%), however I deem that acceptable! B-) Sapphire R9 290 BF4 edition. I also have a box fan blowing across it to help with cooling...

    I could use some help though, I'm trying to run 6 of them in Windows... But can only get 5 of them to actually run. The 6th shows up in device manager but has the "code 43" driver error :(

    Any ideas??
  • try with --thread-concurrency 10240

    (2560 * 4 as in cgminer manual)

    and go stock clocks first.

  • edited January 2014

  • dast,

    I am also getting the same error:

    Maximum buffer memory support says 536870912. Your scrypt settings come to 2147287040. Decrease TC or increase LG.  

    I am running dual Sapphire R290s.

    So once I got that error I a ran this:


    Now my GPus are failing. Any know why?

    Thank you in advance.


  • cdfrp,

    try my bat file. it gives my sapphire two 290s  a decent 870kh/s and is rock solid  (have so far only interrupted cgminer running these settings myself for fiddling around with other stuff). put the below in a file which you name anything.bat. obviously set the file location correct for your computer :)


    C:\cgminer-3.7.2-windows\cgminer.exe --scrypt -o YOURPOOL -u yourusername.yourworkername -p x -g 1 -w 512--lookup-gap 2 --thread-concurrency 24550 -I 20 --auto-fan --gpu-fan 65-90 --gpu-engine 995 --gpu-memclock 1495 --gpu-powertune 20 --gpu-vddc 0.990 --temp-target 80 --temp-overheat 85 --temp-cutoff 92 --temp-hysteresis 3

  • 'set' creates the environment variable assignment for the current command shell (Win or linux).

    'setx' puts the variable assignment into future command shells for the current user account but does not create the environment variable association for the currently running command prompt (Win only, linux users add 'set'(s) and 'export' to .bashrc).
    -see 'set /?' and 'setx /?' for further clarification.

    If all your GPUs have more than 2GB of RAM, you can add "GPU_FORCE_64BIT_PTR = 1" into the environment to avoid pointer issues with dynamic allocations > 2GB.

    Current runtime environment controls:
      AMDAPPSDKROOT={path to SDK}  # (likely set during installation of the SDK)

    *N = number = 1 to 100 (interpreted as a percentage)

  • Here is my setup:

    My setup x2 r9 290 PowerColor (Now running at 1.712Mh/s)

    I have spent 3 wasted days trying to sort out getting my cards above 500 kh/s.....ahhhhh Anyway here is my solution to finally sorting it out:

    1. You need windows 64bit (32 bit didn't work for me)
    2. SDK 2.9 or latest
    3. Latest Catalyst 13_12
    4. Cgminer 3.7.2

    5. Add these commands one at a time by clicking on start and pasting into the space that says "search programs and files"



    6. IMPORTANT I needed 8GB of RAM install in the PC (as I couldn't get the thread concurrency (TC) above 8192 with only 4GB of Ram) I was getting -4 errors when running cgminer and LOTS of Hardware Errors (HW).

    7. I have used the following cgminer.conf for two cards (probably needs tweaking but I'm happy at the moment):

     "pools" : [
     "url" : "Add your pool address here",
     "user" : "Your user name",
     "pass" : "Your password"
     "intensity" : "19,19",
     "vectors" : "1,1",
     "worksize" : "512,512",
     "kernel" : "scrypt,scrypt",
     "lookup-gap" : "2,2",
     "thread-concurrency" : "33280,33280",
     "gpu-engine" : "967,967",
     "gpu-fan" : "50-85,60-85",
     "gpu-memclock" : "1500,1500",
     "gpu-memdiff" : "0,0",
     "gpu-powertune" : "11,11",
     "gpu-vddc" : "1.032,1.032",
     "temp-cutoff" : "92,92",
     "temp-overheat" : "85,85",
     "temp-target" : "80,80",
     "auto-fan" : true,
     "api-port" : "4028",
     "expiry" : "120",
     "gpu-dyninterval" : "7",
     "gpu-platform" : "0",
     "gpu-threads" : "1",
     "hotplug" : "5",
     "log" : "5",
     "no-pool-disable" : true,
     "queue" : "1",
     "scan-time" : "60",
     "scrypt" : true,
     "temp-hysteresis" : "3",
     "shares" : "0",
     "kernel-path" : "/usr/local/bin"

    Oh yes for the TC I also needed to use multiples of what my cards shaders are. i.e my shaders = 2560 therefore 2560 x 13 = 33280 before I added extra RAM I couldn't get the TC above 8192.

    The two cards are running at 800W (total including motherboard etc) I'm sure I will beable to reduce that now I've got it working Wink

    Oh and the cards are running at 77oC & 83oC
    So that is my solution thanks to all comments here.......

    I've just started using CGWATCHER to control all my differn't rigs its really impressive...give it ago....

Sign In or Register to comment.