Noob 2 cards problem

edited January 2014 in Hardware support

I'm new to mining and have successfully setup a couple of computer with 1 card. Now I'm experimenting with 2 cards and I cannot get it right. I have the following config:

Mother : Asus M4A89GTD PRO/USB3
Card #1 : Sapphire 7850 2Gb 
Card #2 : Gigabyte 7850 2Gb
PSU: Kanji 800w
OS: Win7 x64
Catalyst: 12.4 
cgminer: 3.72
Command Line arguments: cgminer.exe -o -O user:password --scrypt --thread-concurrency 8192 -g 1 -I 18 -w 256

The problem is that GPU0 mines 50KH/s and GPU1 300KH/s. 

When I unplug anyone of the cards, without changing the PCIE slot, the remaining card mines 300KH/s

I don't know why this happens. I would appreciate any suggestion

Thank you!


  • Nice setup, thanks for all of the info. I'd run into this when I didn't call out the devices (-d).  I took your config and modified it slightly. Try this instead:

    cgminer.exe --scrypt -o stratum+tcp:// -O user:password -d 0,1 -g 1 -w 256 --thread-concurrency 8192 -I 18
  • Hi,

    I've tried changing the config as you suggested, but the issue persists. I've copied cgminer output for you to see GPU performance.

     cgminer version 3.7.2 - Started: [2014-01-15 15:39:17]
     (5s):346.0K (avg):369.1Kh/s | A:3696  R:96  HW:0  WU:336.6/m
     ST: 2  SS: 0  NB: 6  LW: 102  GF: 0  RF: 0
     Connected to diff 64 with stratum as user xxxxxxx
     Block: 8028250d...  Diff:3.89K  Started: [15:49:16]  Best share: 3.02K
     [P]ool management [G]PU management [S]ettings [D]isplay options [Q]uit
     GPU 0:  48.0C  40%    | 53.02K/53.00Kh/s | A: 640 R: 0 HW:0 WU: 44.9/m I:18
     GPU 1:  61.0C 3048RPM | 318.8K/317.6Kh/s | A:3056 R:96 HW:0 WU:291.8/m I:18

    Thank you!
  • edited January 2014

    On a 7950, for g=1, thread-concurrency should be at 22400.  With g=2, you must use thread-concurrency=8192.

    I find I get slightly better hash rates on my 7950s with the g=1 setup.

    Try increasing your thread concurrency and see if that helps with your 7850s.
  • Hi,

    Thank you for your suggestion. I tried increasing thread concurrency but I think 8192 is max for this card. cgminer wont start if I increase the value.

    I continued testing different things:

    - I added a second PSU for one of the cards, a Sentey BRP500w.
    - I added +2Gb RAM (4Gb total)
    - I tested both cards together on another motherboard+micro+memory

    Result: same situation. One card ~300KH/s and the other ~50KH/s... 

    I would appreciate any help!
  • If you are receiving the Maximum buffer error when trying to increase the TC over 8192 then run setx GPU_MAX_ALLOC_PERCENT 100 and setx GPU_USE_SYNC_OBJECTS 1 from a cmd prompt.

  • Hi,

    I will try setting those variables, but anyway, shouldn't each card mine with 8192 threads, or threads are distributed by cgminer between cards?

    Thank you for helping me.
  • Hi,

    I've set both variables and increased thread concurrency to 16384, but although KH/s increased, still one of the cards mines much less than the other. The second card stays at 50KH/s.

    I'm updating W7 right now and will try to upgrade Catalyst to 13.12.

  • At last its working!! I updated W7 and installed Catalyst 13.12.

    Thanks to everyone for helping me.
  • Awesome!  Glad to hear you're up-and-rockin'!

Sign In or Register to comment.