One card fails to start, most of the time...

edited December 2013 in Hardware support

Ok, go I have 3x Gigabyte 280X, decent Asus mobo that can deliver enough power to all three cards and the usual crap system just to make it work (Celeron, couple GB RAM, small HDD). I have an issue where one of the cards (randomly picks between the three) will either not start hashing at all, or at a very low rate (like 2-3Kh/s). The other two cards run just fine and dandy.

If I quit and restart cgminer (tried both 3.7.2 and 3.6.6) multiple times, sometimes 50 restarts, finally all three cards will work properly. Normally the AMD display driver will crash and restart about every other restart of miner as well. If I leave it running with just two cards hashing, cgminer will normally crash after a minute or two.

Sometimes I noticed it will work if I have Trixx open, sometimes if I have it closed so I don't think that is making a difference. It's clearly an AMD driver issue. I just moved up to the newest version of Catalyst (13.12) with the latest driver ( and it has made no difference.

My config as follows:
-i 13, vectors 2, worksize 256, lookup-gap 2, thread concurrency 8192, shaders 2048, gpu-engine 1034, gpu-memclock 1500, powertune 20, gpu-threads 2

These settings work just fine, and then I use Trixx to adjust voltage to 0.999 (it works - gets me over 720Kh/s when it works right). I can't for the life of me figure out why one randomly selected card will fail to start properly each time I start cgminer. Any clues?


  • edited December 2013

    Ah ha!

    If I remove gpu-threads from my conf file it all works fine but my hash rate is only around the 540Kh/s mark. Also works if I set it to 1 instead of 2, but with the same low hash rate.

    Any advice on getting those threads up and still have all three cards run?

    Just as a note, the system ran fine with 2 cards at threads 2. I have a Corsair 1000W PSU in case anyone is wondering if my cards are getting enough juice.
  • Hi,

    we need a little more input there.

    1) os ? I would suggest uninstalling + installing the driver either way, but I guess you will need help with that if you are using linux ;)
    2) Your command line looks kind of broken to me.
    It usually looks like --[option] [value] --[anotheroption] [anothervalue] without any "," between those.
    The "," are used to separatetely set instructions for the different cards, e.g.
    --gpu-engine 1000,1100,1200 for card 0, 1 and 2.
    (There are exceptions to --[option], e.g. the "g" option only uses one "-" (-g X))


  • OK,

    I am pretty fluent with Linux, but that aside I am using Win 7 64bit. Drivers uninstalled (properly!) and reinstalled countless times. Also tried various versions of catalyst and driver (13.10, 13.11, 13.12 and associated drivers).

    I use a conf file, it is layed out correctly with all necessary " and , - I just typed in my values into the post real quick so you know what settings I have.

    I am thinking I might try running two instances of cgminer with one handling two cards and another handling the third. Just to see if I can get all three running correctly with 2 threads each.
  • Well it might sound stupid, but if it's not the config: The only time I had such a problem on my rigs was when they had residual voltage.
    I noticed that when I wanted to do a cold boot and it didn't turn on at all. Before that I also had a little joker jumping between the cards and holding one back ;)
    So I suggest to turn the rig off, cut the power and hit power on like 10-20 times. That fixed it for me at last.

    The driver crashing is really bad though. Does AMD have some kind of cleaner ?
    Otherwise you might want to look for driver sweeper, it (sadly) does more than the vendor tools.

  • Voltage doesn't appear to be an issue, powered off, unplugged, left for a bit. No difference.

    AMD has an uninstaller but it leaves traces behind so I use sweeper indeed.

    This definitely revolves around gpu threads. 1 is fine, 2 always leads to one card hashing at about 2-3Kh/s. I can run with 1 thread and its very stable, but each card is about 200Kh/s slower than what it's capable of.
  • Strangely if I use GUIminer (I know, just trying something here!) My first card is running at 660Kh/s, second is at 630Kh/s, and the third still runs like poop. But because I can run each card in its own instance, if I set the third card to threads 1 it gets up to 500Kh/s.

    So overall 1790Kh/s, which is better than running all three with 1 thread in CGminer which gets me about 1620Kh/s and mega instability. I would rather have all three running 2 threads in CGminer though and get back to 720Kh/s per card!
  • Right, update. I now have GPUs 0 and 1 running in CGminer, both at full speed as expected. I disabled GPU 2.

    GUIminer is now running GPU 2 and that is getting good hash rates too (not quite as high as the 2 in CGminer, but I expected that because GUI is, well, its GUI...)

    I have a couple of workers, one for CG and one for GUI to prevent any problems with setting difficulty. It's a crap solution but its working for me right now. It does however lead me to think that CGminer is in fact the cause of the issues as all three cards can clearly handle 2 threads each. I tried a couple of versions of CG but got the same problems.

    Either that or Windows is having troubles with 6 threads in one program? I think it may be worth my while running Linux to see if that is any better.
  • cgminer is definitely able to handle the threads.
    I run 3 cards with -g 2 and there's plenty of people running more cards on one instance.

    As far as windows goes it only has problems with more than 4-5 GPUs.
    Also, how long do you wait until determining that one cards doesn't come up right ?

    On my rig one card comes up with lower KH/s from time to time too, but then catches up after ~1 minute.

  • I read the best drivers to use was v12.8, as the newer drivers can cause problems for miners.  I'm no expert, only been in the game for a short time, but I've seen this written a lot.

Sign In or Register to comment.