Help with r9 280x vapor-x config

edited February 2014 in Miner Configs

Hi poolmates
I have decided to give it a try and dive into mining business I have just bought r9 280x vapor-x card and installed it in my PC .. (I bought and 850W GOLD PSU) Then I start searching for a good config
for the cgminer so I can get 700-750khs ... but whatever I have tried .. my best stable result is 540khs .. here is my best config so far
start /high cgminer --scrypt -o stratum+tcp://ltc.give-me-coins.com:3333 -u pslabakov.bobs_gpu -p x -o stratum+tcp://ltc-eu.give-me-coins.com:3333 -u pslabakov.bobs_gpu -p x --intensity 13 --worksize 256 -g 1 --lookup-gap 2 --thread-concurrency 24000 --gpu-memclock 1700 --gpu-engine 1100 --temp-target 72 --auto-fan --temp-cutoff 90
I also have some question
1. why some uses big thread-concurrency while others use 8192
2. Why do I need to isntall AMD SDK
3. Why do I need to set those enviroment parameters

setx GPU_MAX_ALLOC_PERCENT 100 setx GPU_USE_SYNC_OBJECTS 1
4. Why most of you when overclocking do not increase the default memclock 1550 and engine clock 1070

I ask those qquestions so I can try to understand how tweaking is done

Thanks in advance

Comments

  • Big thread concurrency goes with -g 1,  The 8192 thread concurrency is for use with -g 2.

  • Where the hell do you get so complicated settings ?

    The solution is simple : check this table and copy the settings which achieve highest hashrate for the same card as yours :

    https://litecoin.info/Mining_hardware_comparison

  • edited February 2014

    Hi
    I have tried a lot of configurations including changing the bios version of the card and mining from BAMT  ..
    but no luck at all .. just managed to make it to 635khs by increasing the gpu-engine to 1180 .. could it be my motherboard or pci-e underpowored ?!?

    could it be that my PCI-E x16 slot is v2.0

    imageimage


  • Try lower your settings.  A lot 280x I've seen are running stable between 700 to 750 hashrate with the following settings:


    -g 2 -w 256 -I 13 --lookup-gap 2 --shaders 2048 --thread-concurrency 8192 --gpu-engine 1030 --gpu-memclock 1500

    you can try different numbers for --gpu-engine to get your best hashrate
  • Hi all
    just want to let you know I managed to sqeeze to 710khs .. What I had to do is undervolt my bios using VBE7 like this
    image
    and then using this settings
    -I 20 --thread-concurrency 24000 --gpu-engine 1044 --gpu-memclock 1500 -w 256 --auto-fan --temp-target 71 --temp-overheat 85 --temp-cutoff 90
    I got steady 710khs now with 68C and 1900rpm
    If you can think of something new to try .. feel free to write ;)

  • try TC 22336. That should get you a few kh more.

  • edited February 2014

    @cytocon
    Thanks for the hint .. btw I am using using a kernel file from here
    http://www.reddit.com/r/litecoinmining/comments/1va8g2/ann_sgminer_400_release/ using tc24000
    If I set tc to 22336 with kernel generated from my cgminer I get 620khs .. if I use the one from the url I get nothing but HW errors

  • Here you go, you should boost to 740 Kh/s with this settings


    -I 13 -w 256 -g 2 --shaders 2048 --thread-concurrency 8192 --lookup-gap 2 --gpu-engine 1070 --gpu-memclock 1500 --gpu-powertune 20 --gpu-vddc 1.100 --auto-fan --temp-target 72 --expiry 1 --scan-time 1 --queue 0

Sign In or Register to comment.