Sapphire HD 7950 cards causing mobo to shut down

edited January 2014 in Hardware support
Hey, everyone.  I recently started litecoin mining and I'm running into difficulty keeping my rig running.  It shuts down randomly and won't start up again until I remove one or two of my three video cards.  I don't even get beeps from the motherboard, it's just completely dead.

The first time it happened I removed one video card and it ran fine for a day or two and then died again.  Then I removed another card and it ran again with just one card.  I ran it that way for a day or so and then tried plugging and unplugging the second card until the rig powered up.  It ran for a couple hours and then died again.  I think I saw a little puff of smoke come out of the second card when I tried to power it up after that failure.

I've tried breaking the rig down and re-seating everything but that didn't help.  I've tried the video cards in different PCI slots.  One card will run fine in any slot, the other two won't run (or run only sporadically) no matter which slot they're in.

My setup is as follows:

Software:
Ubuntu 12.04
CGMiner 2.11.4
AMD Catalyst 13.11

Hardware:
Sapphire HD 7950 Dual-x (x3)
Asrock 970 Extreme4
Seasonic Platinum-860 ATX
AMD Sempron 145
G.Skill Ripjaw 4GB DDR3

Generally I run cgminer pretty much in the default config.  I use -I 18 because that seemed to give me the best hash rate.  I've overclocked the GPU to 1060 and underclocked to 800 and the rig fails either way.  Most thread concurrency settings throw a lot of hardware errors so I left them out.

I don't think GPU temps ever exceeded about 75C.  Most of the time they run in the 65-70C region.

At this point I don't know if I need a new PSU or to get a refund on the video cards.  It's been kind of frustrating.  Any ideas are appreciated.

Comments

  • First try your cards on another computer, test them one by one.

    If you don't undervolt your cards, 860W PSU may be a little short (I'm using 1 HD7950, I've 370W on the wall plug, my mobo take about 150W, so 3x7950 + mobo would take 3x220+150 = 810W for me).

  • I'll give that a shot.  It seems strange that two cards won't run at times either.  That should be only about 500W or so power load. Anyway, I'll try the cards on another computer.  I appreciate the help.

  • Well, it seems to have been a PSU issue.  I plugged the three cards into my second rig, which has a Corsair 1000W PSU and they all came up right away and stayed up.  Looks like I'm buying a new PSU.  Thanks for the help.

  • Ah, I was going to suggest that it was a power problem, it looks like you found out though.  Shutdowns like that typically are.

  • Well, the 1000W PSU is better but it's still having problems running with all three cards.  It shuts off occasionally and I have to unplug one card to get it running again.  I might try to hook up both the 860W and 1000W PSUs to the one board.  Has anyone tried Add2PSU before?

  • edited January 2014

    You should undervolt your cards. It makes a big difference in power consumption. My sapphire 7950 vapor-X run at 900 MHz 980 mV, only 550 kh/s each but they're very stable, nearly silent and not electricity hungry. Temps are in the 58-60°C range with factory fan settings (between 1600-2000 rpm). I undervolt with Trixx in Windows ; I know there are ways to undervolt in  Linux too but I can't help you with that.

  • I haven't been very successful undervolting in Linux.  I'm thinking of switching over to Windows to see if that works.  With no undervolting, it seems like a 1000W PSU falls just short of my power needs (which seem to be around 1050W with three cards).  Undervolted I should only need ~870W or so.  The good part is the rig has been running non-stop for several days with just two cards so she's otherwise stable.

  • I'm running 6 Sapphire 7950 cards, so I HAD to undervolt. I too had problems undervolting in Linux using the atiflash program. The sequence was to run atiflash on linux to suck out the roms, move them to a windows box and run the VBE7 to edit the voltages, move the edit rom files back to the Linux box, and flash the boards with them.   What I found was that the Linux version of atiflash has a tendency to quit with a "FL01" error at random points in the flashing.  Repeating the attempt will quit at a different point, sometimes further along, sometimes shorter.  Eventually, with enough tries, it does complete.  There will be a message confirming success and telling you to reboot.

    There are two potential gotcha's along the way.

    The first is when the transfer gets far enough to copy the "I'm Programmed" flag, but does not complete.  Subesequent attempts will nor run, saying "This board is already programmed".  The fix is to run atiflash once with the "-f" flag (force) added to the command line.  Normally, it's best to run without the -f flag to allow checksum verification to be performed.

    The second is that, sometimes, rarely, when flashing the card that you're using for the video monitor, the atiflash failure will hang the video card, requiring a hard reboot.  Linux will not recognize the card and leave you with a black screen.  But fear not, all is not lost.  Simply move your monitor connector the card that was labeled as "gpu #1" and you will get your screen back.  Atiflash will still recognize all cards (you can verify this with "atiflash -ai"), and you can complete the flashing process.

    Hope this helps you get your 3 cards running under Linux!
  • @edwardc


    Thanks for that.  That should help me move things along.  So are you running a single PSU on that setup?
Sign In or Register to comment.