Cgminer and two cards crasching all the time

edited January 2014 in Hardware

Hi there all I need some help configurationg this cards: AMD Radeon Radeon HD 4670 CGminer is crasching at the first line all the time. The cards are present in the Device manager and working. Running win7.


 This is my config file:

],
"intensity" : "13,13",
"vectors" : "1",
"worksize" : "256",
"kernel" : "scrypt",
"lookup-gap" : "0",
"thread-concurrency" : "8192,8192-g1",
"shaders" : "0",
"gpu-engine" : "1140,830",
"gpu-fan" : "90",
"gpu-memclock" : "1400,700",
"gpu-memdiff" : "0",
"gpu-powertune" : "20",
"temp-cutoff" : "95",
"temp-overheat" : "85",
"temp-target" : "75",
"api-port" : "4028",
"expiry" : "120",
"gpu-dyninterval" : "7",
"gpu-platform" : "0",
"gpu-threads" : "1",
"log" : "5",
"no-pool-disable" : true,
"queue" : "1",
"scan-time" : "30",
"scrypt" : true,
"temp-hysteresis" : "3",
"shares" : "0",
"kernel-path" : "/usr/local/bin"


Any good ideas what to do?

Regards
Appen

Comments

  • Yes, remove the -g1 after the 8192 in your thread-concurrency line.  That's an invalid command.

  • Thanks for the reaply, but I can't be that, when dissable the second card it runs good on one card using the same config. But i will take it away.

    Regards
    Appen

  • Based off what you wrote above, that correction should be made and it should read this:


    ],
    "intensity" : "13,13",
    "vectors" : "1,1",
    "worksize" : "256,256",
    "kernel" : "scrypt,scrypt",
    "lookup-gap" : "0,0",
    "thread-concurrency" : "8192,8192",
    "shaders" : "0,0",
    "gpu-engine" : "1140,830",
    "gpu-fan" : "90,90",
    "gpu-memclock" : "1400,700",
    "gpu-memdiff" : "0",
    "gpu-powertune" : "20,20",
    "temp-cutoff" : "95,95",
    "temp-overheat" : "85,85",
    "temp-target" : "75,75",
    "api-port" : "4028",
    "expiry" : "120",
    "gpu-dyninterval" : "7",
    "gpu-platform" : "0",
    "gpu-threads" : "1",
    "log" : "5",
    "no-pool-disable" : true,
    "queue" : "1",
    "scan-time" : "30",
    "scrypt" : true,
    "temp-hysteresis" : "3",
    "shares" : "0",
    "kernel-path" : "/usr/local/bin"
  • No did not work, same as before. 


    After I enable the card and trying to start CGminer it stop direct, then I disable the  Radeon HD 4670 I cant start CGminer, i always have to reinstall the Catalyst 13-12 again, then CGminer works using one card.



    Regards
    Appen
  • Are they in Xfire? If so try disabling.

  • Hmmm where is that one?



    regards
    Appen
  • Xfire = Crossfire

  • HI again, sorry have no clue to what you are refering to.


    Rgerads
    Appen

  • edited January 2014

    See the small ribbon cables connecting the top of both of these Radeon 4670's?

    HIS H467QT512P HD 4670 Crossfire

    *Remove* these cables if yours are in this configuration.  Having them plugged in enables Crossfire.

    (Image courtesy of TomsHardware)
  • Ok thanks, one of the cards had that cable plugged in, but no different still same problem.....




    Regards
    Appen
  • Try a bare-bone cgminer run with no config.  At the end of the cgminer statement with your pool address, user, pass, etc. you may still have to specify -d 0,1


    Do both cards work?
  • Appen,

    You could try running cgminer from a command line / batch file.  Then, from the interactive screen, press S for settings and W for write if I remember, to write a config file.  Look at the options on the screen to be sure.  This will write out a properly formatted config file, which you can then edit, in case you've missed some commas, quotes, etc.  Set your cards engines to their default clocks, no overclocking at first.  You may even want to drop the intensity to 12 on each one just to make sure they're running slow and stable.  Don't worry about how fast until you get them going.  If you have to, you could physically remove one card and run the other.  Then swap them out.  Once you know each one works, you can go back to the pair.  Once you get them both working, you can up the clocks and intensity.  You may also want to reduce the thread concurrency to 3200 or something.  I think I have a 6000 series card running that way.

    I just remembered, I have a 4670 sitting on the shelf.  I never could get it to work for this.  It may be incompatible with cgminer.  For my more modern cards such as 7850's, I have thread concurrency set to 0; except that, on the one driving my monitor, it's 8192.  On the others, cgminer seems to figure out what to do.

    Sincerely,

    Ron

  • edited January 2014

    I had a similar issue, I have [2] Sapphire R9 290 cards which have been runing rock solid for 4 weeks, all of the sudden my system would lock up after about 2 minutes of mining. If I ran [1] card by itslef the issue stopped however I couldnt get [2] cards working together [nothing had changed].

    It had me stumped in the end my issue was fixed by removing the [--gpu-fan 30-90,30-90] setting from my config and the issue has gone away. I still have the --auto-gpu switch enabled and I let the cards themselve dicate fan speed.

     

    Rgds

    underminer

    Litecoin: LL2aj4BTdkkAwpcqEuooZkvdbgAiLywrMZ

    Feathercoin: 6rehpXv9eqjHudHR9WVjZs9QG88yFuxeqb

  • edited January 2014

    Your settings are completely wrong. I don't know the exact thread concurrency for 4670, but it's certainly not 8192. Worksize should be 64 not 256. You're using settings that are for cards 50 times more powerfull than yours, that can't work !

    Use google if you want to find proper settings for 4670. But I suggest getting cards adapted to mining. Your cards are too old and weak, they are nearly useless. They won't pay back the electricity you'll be using.

  • Hi  I currently run a HD 4670.  As cytocon said above:

    Your worksize needs to be changed to 64
    Start your thread concurrency around 4200 and play with the numbers from there (I am still playing with these numbers)


    I get around 40-50kh/s

    Bitcoin:1Lf8vZd3xzwR5PoVQShMNcJaxXGbMemk2U
    Coino:Uj71NKfx9MPq7vpznKBb9YLZ2oZZyFcopZ
    Mintcoin: MfiRLCLrhkT5bP5kYAQZgdFhbwZtAf7Lsh



Sign In or Register to comment.