Guide to setting up xubuntu for stand alone rigs UPDATE v0.9.1

edited December 2013 in Miner Configs

This is a guide to setting up xubuntu 12.10 with all required software and drivers (AMD 13.1 and SDK 2.8 these driver seem to be the most stable) for use as a dedicated mineing rig.
It can be installed to and run from an 8Gb or larger USB memory stick or hard disk.
As this is a full xubuntu install you can also if you wish use any of the available ubuntu software packages and make use of the virtually unused CPU in your rig to run further applications i.e. web server, media server,file server etc if installed to hard disk without affecting your miner.
At the moment the instructions for the mineing software itself are for latest bfgminer (fork of cgminer) and cgminer.
I will be adding instructions for using [url]http://anubisapp.com[/url] soon to enable remote monitoring.
It is a work in progress and any feedback is appreciated and will be incorporated into the document.

Guide http://tinyurl.com/cboxzdy

Version 0.9.1 Latest   Updated xubuntu download link and added warning about cgminer dropping support for gpu mining also update to use only   bfgminer 3.2 for  gpu support

 Version 0.9 old
 Version 0.8 old 
 Version 0.7 old
 Version 0.6 old
 Version 0.4 old
 Version 0.1 old

Comments

  • Hey man I followed your guide with cgminer but my system crashes if I set "Intensity" above 12. If i leave it at 12 I'm only getting 260 Kh/s . I have a 7950 so I should be getting 600 Kh/s aprox. What can I do?

    My settings:

    My rig:

    Hardware
    GPU: 7950(1); RAM: 4GB; PSU: 850w;Mobo: HP 3031h (I took it from my old computer); Processor: intel dual core.

    Software
    OS: Xubuntu;

    Cgminer’s config:
    My launch file:

    #!/bin/sh
    export DISPLAY=:0
    esport GPU_MAX_ALLOC_PERCENT=100
    export GPU_USE_SYNC_OBJECTS=1
    cd /home/templar77/cgminer
    ./cgminer –config ./cgminer.conf

    And my config file:

    {
    "pools" : [
        {
            "url" : "http://ltc.give-me-coins.com:3333",
            "user" : "Templar77.1",
            "pass" : "x"
        }
    ]
    ,

    "intensity" : "10",
    "vectors" : "1",
    "worksize" : "256",
    "lookup-gap" : "2",
    "thread-concurrency" : "16384",
    "shaders" : "1792",

    "gpu-engine" : "1125",
    "gpu-fan" : "40-100",
    "gpu-memclock" : "1250",
    "gpu-powertune" : "20",
    "gpu-vddc" : "1.100",
    "temp-cutoff" : "99",
    "temp-overheat" : "95",
    "temp-target" : "80",

    "api-port" : "4028",
    "expiry" : "120",
    "failover-only" : true,
    "gpu-threads" : "2",

    "log" : "5",
    "queue" : "1",
    "scan-time" : "60",
    "temp-hysteresis" : "3",

    "scrypt" : true,
    "kernel" : "scrypt",
    "kernel-path" : "/usr/local/bin"
    }


    Thanks!

  • edited November 2013

    i would suggest sticking with bfgminer as i have found it much more stable

    Also what make gpu is it some will not do that high a core clock speed
  • bump for updated version

  • Why do you recommend SDK 2.8?  I've heard it's buggy, and I just noticed 2.9 came out prior to the last update to this guide.

  • not sure, i know this tutorial is pretty old, but i tried for a few days and couldnt get either miner working on xubuntu. and a lib.0.1 error, the solutions online didn't help that i found. not sure what i going on

  • edited December 2013

    Looking into it, is that all it says in the error ?  and its been updated  recently :)

  • edited December 2013

    "Why do you recommend SDK 2.8?  I've heard it's buggy, and I just noticed 2.9 came out prior to the last update to this guide."

    2.8 works just fine :) and 2.9 is buggy to say the least
     
    This guide uses the most stable combination of drivers etc
  • edited January 2014

    Any idea why, when I try to restart bfgminer with a script run in cron I get this is syslog and bfgminer fails to start:


    bfgminer[xxxx]: segfault at xxx ip xxxxxx sp xxxxx error 4 in libamdocl32.so

    Edit :

    Seems that I should use user cron not root cron. Works now :)
  • Hey All,

    I've followed the guide and my rig is running pretty well for hash rates.  I do have one annoying problem.  A couple of times per day, my CPU pegs to 100% and when I look at what is doing that, it says Xorg.  I'm running the rig headless, but possibly some X11 process is popping up on the display and hogs all the CPU?  The 100% CPU causes my miner processes to hang or shutdown.  restarting the rig and it works great for like 12-24 hours before the same thing happening again.
    Anyone seen the same thing with xubuntu and can help?
  • did you disable all screen savers ?

  • I must have had my OS packages in a weird state.  I did sudo apt-get update, and then re-installed the AMD drivers, and it hasn't happened for the last couple of days.

  • Nice glad you got it sorted

  • if you're still seeing low hashrates and/or freezing, you may try switching your lookup-gap to 1 instead of 2.  in the HW comparison wiki, all 7950's have a gap of 1.  


    It does make a difference......
Sign In or Register to comment.