5970 (Stock)

edited 10:59PM in Miner Configs
I will get things started in here by making a topic for 5970. Feel free to put you 5970 configs in here.

The best one i found which was giving me around 350 - 353 per core is below:

color 02
cgminer --scrypt -o stratum+tcp://stratum.give-me-ltc.com:3333/ -u worker -p pass --shaders 1600 -I 18 -w 128 -g 1

NOTE: This is a cgminer command that is run from a batch file.

Feel free to pick it apart and make a better one :)

Comments

  • edited August 2013

    This is the config I use for my dual 5970 setup - remember FANS are cheaper to replace than cards themselves, so I run mine at 100% to promote longevity of the card(s). This config runs each core at a comfortable and stable ~333KH/s without cooking them - about 72 degrees Celsius peak temp usually. Never crashes :-B

    color 04
    cgminer --scrypt -o http://stratum.give-me-ltc.com:3334 -u USERNAME -p PASSWORD --lookup-gap 2 --gpu-fan 100 --gpu-memclock 1000 --gpu-engine 730 --thread-concurrency 8192 -g 1 -I 17

    Oh, and ~2% stale rate if that...

  • Hey guys,


    I just purchased a 5970. I have been mining with a 7870 and a 5870 together for quite some time now.
    Today, I replaced the 5870 with the new 5970 that I got.

    Now, I can not get cgminer to run at all. It just crashes every time I attempt to run it. Does the 5970 not place nice with other cards? I can't for the life of me get cgminer to execute without crashing. Any help would be appreciated.

    I have tried running it with completely stock options (with --scrypt for LTC obviosuly).
  • edited August 2013

    Have you made a new config for the 5970?
    Crossfire mode Disabled? It should be...
    Have you used the -d {device} switch and run a separate instance of cgminer just for the 2 cores of the 5970? My config above works perfectly, just figure out which two devices are the 5970 cores, then add -d 
    then the device numbers seperated with a comma - EXAMPLE:

    cgminer --scrypt -o http://stratum.give-me-ltc.com:3334 -u USERNAME -p PASSWORD --lookup-gap 2 --gpu-fan 100 --gpu-memclock 1000 --gpu-engine 730 --thread-concurrency 8192 -g 1 -I 17 -d 0,1

  • I run my 5970's at default speeds with almost no config settings at all, they seem to be natural born miners!  I simply add --gpu-fan 100 and -I 18 and they are off and mining at 339 khash per core, so 678 per card like a dream every time.  They do run hot but I found they are very stable even in the low 80's


    If anyone had tips on how to reliably and without too much extra heat get a few more khash's out of them I would love to hear it!  I have not tried overclocking or manipulating the clock speeds at all yet. 
  • My 5970 works on GPU defaults with Thread concurency - 6144, and Intensity - 18. As you can see it gives great results 393+391=784 khash/s with 79 degree.

    image

  • I am running my 5970's via bat file, using the following settings *(Including Graff's recommended 6144 thread concurrency) but I am only getting 339 khash's per core which is no were near his 390+ khashs.  Any advice would be appreciated  



    color 02
    setx GPU_MAX_ALLOC_PERCENT 100
    setx GPU_USE_SYNC_OBJECTS 1


    Set PARAM0=--scrypt -I 18 -w 256 --no-submit-stale
    Set PARAM1=--gpu-threads 1 -v 1 --thread-concurrency 6144 
    Set PARAM2=-o ltc.give-me-coins.com:3334 -u x -p x
    c:\cgminer-3.5.1-windows\cgminer %PARAM0% %PARAM1% %PARAM2%
  • Buysmith, I wonder if the reason is in miners. Or maybe in some specifications of the cards. I have XFX 5970 with 4Gb GDDR5

  • Thanks for writing Graff, 


    I have dell alienware 5970's and I am using Cgminer.  I am still looking for figure out how to get more than 339 khash per core ( or 678 per card)  Any recommendations, perhaps even bios upgrades people have done would be great to hear about.
  • Thanks everyone for writing ;-}

    I'm new to LTC Mining.  I'm collecting cards and running a few old HP xw4600's as miners.  My 6th card, an ATI HD5970 will not mine.  I am told by the guy who sold it to me that it's very finicky about the software you use to run it; Catalyst, SDK, DirectX, maybe even what CG you use.  I see alot of issues with 5970's on different forums.

    Do y'all think this guy is full of it, or is this valid?

    My main rig has a Fatality P67 mobo, i5-3450, 16gb, Win7-64.  I wiped all ATI and installed 12.6 with SDK 2.6 and the 5970 would run but sometimes Firefox would crash it, CGM would always crash it.  The crash would show an olive greenish screen with many horizontal lines.

    My main question is what software setups are you running? 

    I've checked the mining hardware comp list and the most it has is 'Ubuntu Server 12.04 x64, Catalyst 11.11, APP SDK 2.5', which ain't going to help me on Win.  May try it anyway as soon as I get my new 1200w psu.

    All input greatly appreciated - thanks

  • edited January 2014

    @Graff,

    Please do you know the GPU speed clock of your gpu's ?
    Normally, it's 725Mhz and 1000Mhz for the RAM.

    The difference could be explained because of the base frequency..

    I think it's this one :
    http://www.avadirect.com/product_details_parts.asp?PRID=19584

  • I believe that is correct - 725 and 1000.  I didn't have much time to look....

  • edited January 2014

    My 5970 works on GPU 795Mhz and 1080Mhz for RAM with Thread concurency - 8192, and Intensity - 18. default vddc = 1.050V. it gives results 370+370=740 khash/s with target 78-80 degrees. Fan 50%.


    So, I wonder how Graf made 393Kh/s ​​with default frequencies (725 - 1000) ??

    this one ? 850Mhz : http://www.avadirect.com/product_details_parts.asp?PRID=19584

  • cool - thanks.  I can't even get to the point of knowing what cg settings I need however because the card will not mine.  Even if I start it with no specifics it just crashes the gpu.  What version of Catalyst are you running?  What SDK?  And what version of cgm?  I would even like to know what DirectX you have if you know.

    thanks


  • I run wither windows 7 fully patched, or windows 8 fully patched ( or just base install ) and then the ONLY drivers/SDK's anything I install is the Cat 13.1 package (it has an SDK built into it )  [also note I have not been successful lately at going backwards on drivers, e.g., if you have 13.9 installed you can not uninstall it and install 13.1, so if this is the case reformat/re install windows, then simply install 13.1]


    Then in Cgminer I have found I am most stable at 750 Mhz GPU and 1000 Mhz Mem with Intensity 18 (would like to push this a bit higher though but haven't had the time to try every setting out there)

    Some cards I have seen are a bit finicky, then setting -I 17 and bumping up the Voltage has helped, so --gpu-vddc 1.05 is default (this means 1050), I have heard going as high as 1.1 is safe and for me usually around 1.09 does the trick if the card needs a little something something.


    Ungaro59 - Yes I believe Graf has the 4gb version instead of the 2gb version.

  • K - I brought home my 1st xw4600 configured with Ubuntu and running a legacy driver for an old HD 4870 card I had laying around (average 100khs - kinda cool).  I'm going to pull the usb stick out and put a hard drive back in, then fresh install of windows 7 and 13.1.  If that doesn't work I'm going to try an Ubuntu set up. 

    BTW - slap me if I'm sharing stuff I should not, but I heard of small little program that resets the grace period of Windows over and over so you don't have to register it.  It sounds like a good thing if your running a bunch of computers just to mine...

  • YES!  formatted the drive, fresh install of Win7 Pro 32 bit (figured it's an old card...) stopped the updates, installed Cat 13.1, then had to install NET frame 4.0, kicked up the fan via CCC to 45%, CG 3.7.2 and the card started to mine!  All be it at about 10 khs a core at intensity 8 ;-).  Added I-12 g-1 w-256 and tc-8192 and got up to about 240 khs per core....then....

    NO! the computer just crashed dead as I was typing this reply....  on the restart it's working again.  No hw errors...  Going to mess with it a bit, though I will probably fall asleep before posting again. 

    Thank you Very Much for the help!

  • Forgot I had not changed the power supply from the 450w to the 750w in computer I used.  Once I did that; no crash.

  • I am nw to litecoin mining, I have an AMD Radeon MSI 5450 1gb video card. I have been trying to get cgminer to work but i get stratum pool 0 interrupted. 


    I have tried to use the BAT file and make a config file and it errors out. I tossed my data and tried GUIMiner and it says connection problem. 

    Can anyone give me a hand at what I am missing or what I need to do? 
Sign In or Register to comment.