HOW TO: CGMiner/Minerd BTC/LTC Miner Setup (WINDOWS)

edited October 2013 in Miner Configs

Hi Guys,


Here is a beginners guide on how to setup your mining software. I will just be addressing getting the miners started and hashing away.

First on the to do list to to get yourself an account with Give-Me-Coins. This is a fairly straight forward experience much like signing up to any forum website, hopefully by getting to this guide you have been able to create an account. Next is to choose your Weapon of Mass Mining (Your Mining Software). There is a huge variety of software out there but the two main ones that have proven themselves at both BTC and LTC mining are CGMiner and Minerd.


Follow the above link to find links to download the software. I would recommend downloading these to your desktop. 

CGMiner:

Open up notepad on your computer and type the following:

BTC Mining: 
cgminer -o http://btc.give-me-coins.com:3335 -u USERNAME.WORKERNAME -p PASSWORD 

LTC Mining: 
cgminer --scrypt -o http://ltc.give-me-coins.com:3333 -u USERNAME.WORKERNAME -p PASSWORD 

Once you have entered the above lines in unbolded text save as in the directory/folder of your cgminer as START.BAT. You need to change the extension of the file, to make sure, you save as "All Files" and then replace the .txt with .bat. This turns the file into a Command Line file that will read what is in the file and execute it thus starting your CGMiner.

Minerd:

Minerd appears to start straight in scrypt mode which is handy given that is really all you would be using a CPU to mine if at all: Same again here open up notepad and saving as START.BAT

minerd --url stratum+tcp://ltc.give-me-coins.com:3333 --userpass USERNAME.WORKERNAME:PASSWORD


«1

Comments

  • Fantastic guide! i will make it an announcment so everyone can see it easily

  • edited October 2013

    Thanks for the guide, it took a little while to start up as I'm using an old video card, but it did start. thanks

  • edited October 2013
    I'll show you how to output a log file from cgminer if people are having trouble launching cgminer.
  • Thanks. But i was ask about mining BTC on minerd. Problem does not dissappears. Minerd works, shares accepted, in dashboard - many GHz+, but 0 (!) confirmed many days. Minerd works to Give-me-coins.com with stratum protocol.

  • Hello, new here and I apologize and thank you all at the same time.

    I am running minerd successfully right now through coinotron, but want to switch over to GMC. I used this setup guide: http://cryptocur.com/litecoin/litecoin-mining/ to get going.

    I have tried using the above and created the start.bat in the same file as the .exe for minerd I have also replaced http with stratum+tcp. and then the

    ltc.give-me-coins.com:3333

    I have even successfully run the proxy. While it is up and running, use the command line and when I run it the window open and closed immediately.

    The below is the line I use in Start->Run

    c:\ltcminer\minerd -a scrypt -r 1 -t 4 -s 6 -o stratum+tcp://ltc.give-me-coins.com:3333 -O user:pass

    (name and pass match that of worker created here at GMC)

    The only thing I can think of is the //: doesnt belong or

    This line form the getting started guide "CPU Miner users: If you use minerd you need to change "http" for "stratum+tcp" on the host configuration"
    Is where I am screwing up. Is that changing something in the litecoin.conf I created in the litecoin folder as mentioned in the guide I referenced?

    Again, thanks in advance.
  • FTC

    minerd -o stratum+tcp://ftc.give-me-coins.com:3336 -O username.workername:password

    -o, --url=URL         URL of mining server (default: http://127.0.0.1:9332/)
    -O, --userpass=U:P    username:password pair for mining server
  • edited November 2013

    WXPsP3:
    When I start the miner with this command:
    I:\cgminer-3.7.2-windows>cgminer -d 0 --scrypt -o http://ltc.give-me-coins.com:3334 -u ThinkFast.xxx -p pass

    I see a blank screen with this:
    [2013-11-21 23:16:50] Started cgminer 3.7.2

    after waiting a few minutes, I do CNTL-C and the I see this:
    Summary of runtime statistics:
     [2013-11-21 23:17:43] Started at [2013-11-21 23:16:53]
     [2013-11-21 23:17:43] Pool: http://ltc.give-me-coins.com:3334
     [2013-11-21 23:17:43] Runtime: 0 hrs : 0 mins : 50 secs
     [2013-11-21 23:17:43] Average hashrate: 0.0 Kilohash/s
     [2013-11-21 23:17:43] Solved blocks: 0
     [2013-11-21 23:17:43] Best share difficulty: 0
     [2013-11-21 23:17:43] Share submissions: 0
     [2013-11-21 23:17:43] Accepted shares: 0
     [2013-11-21 23:17:43] Rejected shares: 0
     [2013-11-21 23:17:43] Accepted difficulty shares: 0
     [2013-11-21 23:17:43] Rejected difficulty shares: 0
     [2013-11-21 23:17:43] Hardware errors: 0
     [2013-11-21 23:17:43] Utility (accepted shares / min): 0.00/min
     [2013-11-21 23:17:43] Work Utility (diff1 shares solved / min): 0.00/min
     [2013-11-21 23:17:43] Stale submissions discarded due to new blocks: 0
     [2013-11-21 23:17:43] Unable to get work from server occasions: 0
     [2013-11-21 23:17:43] Work items generated locally: 0
     [2013-11-21 23:17:43] Submitting work remotely delay occasions: 0
     [2013-11-21 23:17:43] New blocks detected on network: 0
     [2013-11-21 23:17:43] Summary of per device statistics:
     [2013-11-21 23:17:43] GPU0                | (5s):0.000 (avg):0.000h/s | A:0 R:0
     HW:0 WU:0.0/m
     [2013-11-21 23:17:43] GPU1                | (5s):0.000 (avg):0.000h/s | A:0 R:0
     HW:0 WU:0.0/m
     [2013-11-21 23:17:43]

    I:\cgminer-3.7.2-windows>

    Why the miner just hang like that?

  • Why not open a brand new "New Text Document.txt"
    copy paste this one single line into the text file.....

    minerd -a scrypt -r 1 -t 4 -s 6 -o stratum+tcp://ltc.give-me-coins.com:3333 -O user:pass

    Then choose File
    Save As
    pool_give-me-coins_LTC.bat

    Now you can run that Bat file like it were any other .EXE


  • Isn't minerd for CPU mining not GPU?

  • I followed your instructions, but nothing happens...

    I downloaded CGminer... Then I extracted it...
    Then I opened notepad and typed:
    cgminer --scrypt -o http://ltc-eu.give-me-coins.com:3333 -u user.worker -p password
    And I saved it as START.BAT into the folder of CGminer...

    But if I click on START.BAT it quickly opens a commandprompt and ends it right away...
    What am I doing wrong?

    Thanks...

  • Just had the same problem. A small amount of research shows this information at the top to be out of date. cgminer no longer supports scrypt (or gpus). Don't use it. See here.

  • Tried to check my work on this site and says my miner is not active. Tried to browse the net for answer cannot find. Do I need a conf file? 


    color 02
    cgminer --scrypt -o http://ltc.give-me-coins.com:3333 -u worker.1 -p password --shaders 40 --intensity 10 --worksize 256 --auto-fan --auto-gpu -g 1 -l 8
  • Hi efreak,

    You can still use any cgminer up to 3.7.2 with gpu's and scrypt.

    That's what I'm doing.

    Sincerely,

    Ron


  • aftersage,

    Those parameters sound a bit off, especially shaders and intensity.  Tell us what kind of card you're trying to run, what OS, and whether the card is also driving your monitor.

    Ron


  • Hi all,

    I have a problem, I think lol, I am on Windows 7 with an ATI Mobility Radeon HD 5400 Series

    my script is : color 06

    cgminer --scrypt -o ltc.give-me-coins.com:3333 -u neo -p pass --thread-concurrency 400 -g 1 -w 128 -I 10

    but my maximum rate is 16Kh/s !!!!!


    do you have an advice for me please ???


  • If you haven't done this yet, issue this command in a command window and press enter.

    setx GPU_MAX_ALLOC_PERCENT 100

    Then close the window, open another, and type set and press enter.  This environment variable should be set now and should stay set.  Note that this is not part of the cgminer command.  

    It's done separately.

    If the card you're mining on is the same one driving your monitor, you may see decreased performance.  I run my system at a lower setting if the same gpu is driving my monitor so the

    display stays responsive.

    Try this command if running with a monitor and see what happens.  This came from the config for a 5750 from gui-miner scrypt.  It might work with your card.

    cgminer.exe --scrypt -u USER -p PASS -o stratum+tcp://ltc-eu.give-me-coins.com:3334 --gpu-platform 0 -d 0 -w 256 -v 1 -I 13 -g 1 -l 1 -T --thread-concurrency 3200

    Don't try to read this and type it, as it may be hard to read the parameters.  Copy and paste it.  You would have to customize your gpu-platform and device number. The -T option allows the output to be one long series of text lines, which can be useful for debugging.  To exit this mode, press CTRL-C.  If you want a screen where the status updates repaint in the same space, take off the -T.

    Executing cgminer --ndevs or cgminer -n will show the devices, and device numbers, on your system.

    cgminer --help will list all of its commands, or you can check the readme or readme scrypt file in it's directory.

    If the gpu is NOT driving your monitor, you could try this command and see what happens.

    cgminer.exe --scrypt -u USER -p PASS -o stratum+tcp://ltc-eu.give-me-coins.com:3334 --gpu-platform 0 -d 1 -w 256 -v 1 -I 18 -g 1 -l 1 -T --thread-concurrency 0

    Don't try to read this and type it, as it may be hard to read the parameters.  Copy and paste it.  You would have to customize your gpu-platform and device number. The -T option allows the output to be one long series of text lines, which can be useful for debugging.  To exit this mode, press CTRL-C.  If you want a screen where the status updates repaint in the same space, take off the -T.

    The 5400 is not capable of huge hash numbers, but should do better than 16 KH.  If you still have trouble, upgrade to the latest AMD drivers and upgrade to cgminer 3.7.2 from here if it's accessible:

    http://ck.kolivas.org/apps/cgminer/3.7/

    Sincerely,

    Ron

  • edited December 2013

    i have to change -w 256 by -w 128 because i have an error

    and when i start that setx GPU_MAX_ALLOC_PERCENT 100 i have an error too

    thx Ron it's better
    now I have another computer with 2 CG
    1: AMD Radeon HD 7900
    2: NVIDIA GeForce GT 520

    do you have an advice again ? because i think there is just one card on work GPU:0
    and my max rate is 55Kh/s





  • Hi Neoaix,

    Glad to help where I can.

    On the 5400 series card, you could try bumping intensity up one number at a time to see if you can get more hash rate and still have a responsive monitor if it's driving the monitor or still have stability and few rejects if it's not driving the monitor.  I don't generally exceed 19 for intensity at all.

    For the 7900, you could try this:

    If the card you're mining on is the same one driving your monitor, you may see decreased performance.  I run my system at a lower setting if the same gpu is driving my monitor so the display stays responsive.

    Try this command if the card is driving a monitor and see what happens.

    cgminer.exe --scrypt -u USER -p PASS -o stratum+tcp://ltc-eu.give-me-coins.com:3334 --gpu-platform 0 -d 0 -w 256 -v 1 -I 13 -g 2 -l 1 -T --thread-concurrency 8192

    Don't try to read this and type it, as it may be hard to read the parameters.  Copy and paste it.  You would have to customize your gpu-platform and device number. The -T option allows the output to be one long series of text lines, which can be useful for debugging.  To exit this mode, press CTRL-C.  If you want a screen where the status updates repaint in the same space, take off the -T.

    Executing cgminer --ndevs or cgminer -n will show the devices, and device numbers, on your system.

    cgminer --help will list all of its commands, or you can check the readme or readme scrypt file in it's directory.

    If the gpu is NOT driving your monitor, you could try this command and see what happens.

    cgminer.exe --scrypt -u USER -p PASS -o stratum+tcp://ltc-eu.give-me-coins.com:3334 --gpu-platform 0 -d 1 -w 256 -v 1 -I 19 -g 1 -l 1 -T --thread-concurrency 0

    Don't try to read this and type it, as it may be hard to read the parameters.  Copy and paste it.  You would have to customize your gpu-platform and device number. The -T option allows the output to be one long series of text lines, which can be useful for debugging.  To exit this mode, press CTRL-C.  If you want a screen where the status updates repaint in the same space, take off the -T.

    I've never done anything with nvidia.  You'll have to get help from someone else on that.  I don't know if you can simultaneously do amd and nvidia although you might if the drivers don't fight.

    Sincerely,

    Ron


  • Thaks for guide. But minning don´t work. 

    cgminer says:
    Probing for an alive pool
    Pool 0 difficulty changed to 16 
    pool 0 JSON stratum auth failed: (null)
    What is wrong?

  • This sometimes happens when the pool servers are busy.  Make sure you're worker names and passwords are correct.

    You could try this website to test your connection speed to the internet and make sure that's normal for your connection.  I only use the speed test, not the system scan, etc.  If you cannot connect to the net quickly and consistently, cgminer cannot get and send work.

    http://www.speedtest.net/

    Sometimes, the network servers are just slow.  I had a few times when I was getting really low hash rate, so they may have been having problems.  A few times, cgminer shut down and said no servers were available.

    Try stopping and restarting cgminer several times.  After each restart, wait a few minutes to let the hash rate maximize.

    You could also try the other servers.  Even though I'm in the US, I use the EU servers since they seem to be more stable.  This assumes you're mining Litecoin.  Other coins use different servers.

    Server list from here:

    http://give-me-coins.com/support/gettingstarted

    LTC Servers

    US Servers
    ltc.give-me-coins.com:3333
    ltc.give-me-coins.com:3334
    ltc.give-me-coins.com:80

    EU Servers
    ltc-eu.give-me-coins.com:3333
    ltc-eu.give-me-coins.com:3334

    I think there is a way you can program a failover setup in cgminer so it will go to backup pools or servers if some are not performing.  I haven't done that though.

    Sincerely,

    Ron

  • thank you so much rfrazierltc



    I want to buy a new computer, and i need your advice again .... :)

    what you recommend me ? i want to buy 4 Cards

    thanks again

  • Neoaix,

    Not sure exactly what your question is.  Do you want to buy or build?  The following thread talks about a generic parts list for a new rig and some basic costs.  It does not talk specifically about model numbers.  If you have more questions, please elaborate a bit.

    https://forum.give-me-coins.com/index.php?p=/discussion/498/litecoin-miner-building#Item_8

    Ron


  • Hey guys, i'm having an issue with CGminer whenever i use the --gpu-engine flag. i'm running a Sapphire R290X BF4 Edition. it has a stock core of 1000Mhz. however whenever i use the gpu-engine flag even if i set it to 900 (i.e. --gpu-engine 900) my whole system crashes and i need to reboot. if i do not use the gpu-engine flag it mines without issue (however slightly slow) this is the command i am using.

    cgminer --scrypt -o {address} -O u:p -I 20 -g 1 -w 512 --thread-concurrency 32765 -v 1 --lookup-gap 2 --gpu-engine 900

  • For other noobs out thee. If you get the error "ValueError too many values to unpack"...Try lowering the length of your worker's password. My password was 19 characters long (hey, this is good practice in the rest of the world). Brought it down to 6 characters, and the error went away and I'm mining.

  • Hi All,

     

    I have bought the below configuration

    Graphics Card : R9290X 4GB * 2

    Motherboard : G1.SNIPER5

    Intel i7 processor

    CoolMaster Power Supply : 1300W

     

    Installed AMD Catalyst drivers 13.12 , APP SDK 2.9, ADL SDK 6.0

    Cgminer 3.7

     

     

    When I start cgminer.exe Windows is crashing, I have Windows 8.1 64 bit

    Please advise how to overcome this issue

  • Please post your config file for cgminer or batch file or command line.  That may help.  You haven't provided enough data.  How does it crash?  Does it freeze solid?  Does it get sluggish then freeze?  Does the display distort? Is there any kind of error message?  I presume you installed the Catalyst drivers for WIN 8 / 64.  There could be a problem with one graphics card.  Remove one and try that.  cgminer could be working the gpu that's driving your monitor too hard.  Try thread concurrency 8192 and intensity 12 on the graphics card that's driving your monitor.  Try running with no overclocking at all.  I couldn't find what the default clock speed for your card is with a little googling, but try setting it to 900, which may be a bit of an underclock.  You must have enough horsepower left to drive your display without cgminer taking all the gpu cycles.

    Parameters: --auto-gpu --gpu-engine 900-900

    What is the specific make and model of graphics card?

    etc. etc.

    Do some more testing.  Give us more data to munch on.  Then we may be able to help.

    Ron

  • PS, this thread talks about how to manage gpu engine and fan speeds, how to determine which command in the config file is driving which gpu, how to manage heat and temperature, and provides a sample config file.  Disclaimer, I posted the thread, so I'm biased, but I think it contains good and relevant info.

    https://forum.give-me-coins.com/index.php?p=/discussion/666/heat-death-how-to-kill-your-gpu-in-less-than-a-year#Item_2

    Ron

  • edited January 2014
    .
  •  hello i am using AMD Radeon HD 6320 Graphics 

    in cg and bfg i use the following command but after 48 hours got nothing wanna know is it normal ???

    or i m using wrong command??

    my bat contains.............

    bfgminer.exe --scrypt -o ltc.give-me-coins.com:3333 -O user.worker:test


     cgminer.exe --scrypt -o ltc.give-me-coins.com:3333 -O user.worker:test 


    image

  • @Imafia


    Did you fix your error? If not, post a screenshot or a description so I can try and help you
  • Meh! If your run Windows 8, there is a free app in the store! Very very simple. After installation you put your password and worker name in and voila!

  • Imafia, that's a very,very slow card, practically impossible for you to get credited.. You'll be better off hashing with your cpu..

  • anyone know how to fix this. i have 4 rigs that were working fine last week, now only 1 works. here is my first issue on one rig:


    Problem Event Name: APPCRASH
    Application Name: cgminer.exe
    Application Version: 0.0.0.0
    Application Timestamp: 52483164
    Fault Module Name: amdocl.dll
    Fault Module Version: 10.0.1348.5
    Fault Module Timestamp: 52a24325
    Exception Code: c0000005
    Exception Offset: 001326d0
    OS Version: 6.1.7600.2.0.0.256.1
    Locale ID: 1033
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789
  • edited February 2014

    I have installed Windows 7 64bit, cgminer 3.5, and the amd drivers at least 6 times at this point

  • edited February 2014

    i figured it out, will call RF asap, thank you 

  • excuse me all, can you help me with this? am i setting this correctly or not? C:\pooler-cpuminer-2.3.2-win32\minerd.exe -o stratum+tcp://ltc.give-me-coins.com:3334 -u dollar_mining77.1 -p r1k1b0yLC and i'm using cpuminer 2.2.3...makes me really confused.. can i mining at GMC with this? :'( please help me... 

  • @dollar_mining77 Do you have 32 bit windows?  There is a 64 bit version of the miner.

  • @incognitomisquito: I guess i have 32bit windows, because i'm using acer travelmate 4720, intel GMA X3100, windows XP...yesterday i could mine with minerd.exe using Ms.Dos but right now, my PC scan said there's a problem with my minerd.exe :'( have i done anything wrong?? thanks for help incognitomisquito...

  • edited February 2014

    I have seen minerd used in malware to hijack a computer and make it part of a mining botnet.  You will have to make an exception for it in your anti-virus.  The command you have to run it looks right to me though.  To check which version of windows you have (in terms of system architecture), right click computer and select properties.  Under system type it will say 32 or 64 bit. EDIT: Oh I see you have Windows XP, not sure if those instructions will work.  You can also look for a subfolder under C:\Windows called SysWOW64 if you have that folder than you have 64 bit, if you don't then you don't.

  • edited February 2014

     oooh noo... :'( i hope i didn't get my computer hijacked by anyone...so what should i do next?I have to make an exception for it in my anti-virus??do i have to start searching for minerd with 32bit again or anything else? i have search a subfolder under C:\WINDOWS\system32 which means that i have 32bit right?thank you so much for help, if i have bitcoins i'll donate a few for you :)

  • It doesn't mean you got hijacked it just means that some AV brands have added minerd to their definitions since it is being used maliciously.  You will need to figure out how to tell the AV that you want it and not to delete it or quarantine it (and probably restore it from quarantine at this point).  All Windows versions have C:\Windows\System32 but only 64 bit versions have C:\Windows\SysWOW64.  The only reason I asked is because your batch file command indicates you are trying to run the 32 bit version C:\pooler-cpuminer-2.3.2-win32\minerd.exe -o stratum+tcp://ltc.give-me-coins.com:3334 -u dollar_mining77.1 -p XXXXXXX.  If you had 64 bit windows then your problem could be version related but it doesn't sound like it.

  • You do not need the mining proxy.exe to use the current version cpuminer it supports the stratum protocol now it seems. just place the command;

    minerd --url stratum+tcp://ltc.give-me-coins.com:3333 --userpass Drakona.1:123

    in a text firle and rename it to ltcoin.bat or what ever else you want. You will be up and mining right away after doing this. No need to include any special comands either unless you want to try and tweak the miner for better results.

    Though you may want to change the userpass to your own where the first bit(Drakona.1) is your worker and what comes after the :(123) is your workers password. Otherwise your mining for me which I don't really mind if anyone wants to do that too. :P

  •  I use HD 7870 2GB but i run CGminer3.3.3 But I only have 17.00 - 18.00 Kh/s


    Pls help how to solution to rise Kh/s
  • i can't anymore start cgminer, it give me an error Pool 0 slow/down or URL or credential invalids but i copyed everything

  • edited June 2014

    try using port 4334

  • Hi, I'm using 1.3 Fury but I can see to get the right setting have someone here know the right setting I'm using CGMiner v3.1.1 can anyone help please.

  • What is the correct gridseed config to mine only FTC? I'm currently logged in to port:3333 and it appears that I'm mining everything but FTC.. Please help

    stratum+tcp://ftc.give-me-coins.com:3333 is what im connected to.

  • hello guys i have assistance for cgminer ( version with gpu) 


    i have a Sony Vaio VPCCW1S
    with GPU card NVIDIA GT230M 
    CPU Intel Core2 Duo 
    Windows 7 

    and have another pc HP Pavilion DV6 
    with ATI Mobility Radeon HD 4530 
    AMD Turion II Dual Core Mobile M500 2.20GHz
    Windows 7 

    please compile for me the script file bat for launch cgminer? i very desperate please e thank everybody 
    Sorry for my bad english i'm italian XD
  • my worker account is alex7liberti.1 pass vigorsol11 thanks guys

Sign In or Register to comment.