cgminer & Sapphire HD7950 Dual-X - configurations for LTC e FTC

edited September 2013 in Miner Configs
I wrote this in another thread, but I think it's better start a new thread to face up this problem.

well, I have 1 pc that mine ltc or ftc, depending on the profitability. Therefore i use the following configuration file that is the same for both coins.
I have cgminer version 3.1.1, Catalyst 13.4, win7/64. My hw is: 16gb ram, asrock as970, amd sempron 145)
I launch cgminer with this command line: 

cgminer --scrypt -o http://myserverstratum:443 -u myuser.myworker -p mypassword --api-allow --api-listen --no-submit-stale --log 5 2>h:\config\cgminer.log

{
"pools" : [
{
"user" : "myuser.myworkes",
"pass" : "mypassword"
}
]
,
"intensity" : "18",
"vectors" : "1",
"worksize" : "256",
"kernel" : "scrypt",
"thread-concurrency" : "21712",
"shaders" : "1792",

"gpu-engine" : "1030",
"gpu-memclock" : "1392",
"gpu-fan" : "0-100",
"gpu-memdiff" : "0",
"gpu-powertune" : "20",
"gpu-vddc" : "1.100",
"temp-cutoff" : "90",
"temp-overheat" : "80",
"temp-target" : "75",

"api-listen" : true,
"api-network" : true,
"api-port" : "4028",

"auto-fan" : true,
"auto-gpu" : true,
"failover-only" : true,
"gpu-dyninterval" : "7",
"gpu-platform" : "0",
"gpu-threads" : "2",
"lookup-gap" : "2",

"hotplug" : "5",
"log" : "5",
"no-pool-disable" : true,
"queue" : "1",
"scan-time" : "30",
"expiry" : "60",
"scrypt" : true,
"temp-hysteresis" : "3",
"shares" : "0",
"kernel-path" : "/usr/local/bin"
}


It works very well when mine ftc, but with ltc it get too rejected shares. it works fine for 100~200 shares, then obtain 40~50 rejecteds, then my percentage of rejected is 22%. too high.

So, i make a batch file that intercept rejecteds and kill & restart cgminer. 
maybe is there something wrong?
please, help me
thanks

Comments

  • hi jambtc

    look, here my configuration for shapphire hd7950 dual-x:
    {
    "pools" : [
    {
    "url" : "stratum+tcp://yoursite:3333",
    "user" : "yourworker",
    "pass" : "yourpass"
    },
    {
    "url" : "",
    "user" : "",
    "pass" : ""
    }
    ]
    ,
    "intensity" : "20",
    "vectors" : "1",
    "worksize" : "256",
    "kernel" : "scrypt",
    "lookup-gap" : "2",
    "thread-concurrency" : "21712",
    "shaders" : "2048",
    "api-port" : "4028",
    "expiry" : "120",
    "gpu-engine" : "1060",
    "gpu-dyninterval" : "7",
    "gpu-memdiff" : "0",
    "gpu-memclock" : "1500",
    "gpu-powertune" : "20",
    "gpu-platform" : "0",
    "gpu-threads" : "1",
    "log" : "5",
    "no-pool-disable" : true,
    "scan-time" : "30",
    "shares" : "0",
    "scrypt" : true,
    "kernel-path" : "/usr/local/bin",
    "temp-target" : "75",
    "temp-cutoff" : "85",
    "temp-overheat" : "80",
    "gpu-fan" : "80",
    "auto-fan" : "true",
    "temp-hysteresis" : "3"
    }

    i'm using Bamt, linux distro that better windows

    with this config i obtien 640 khs with 1.052% rejected share, in 24 hours

    airing cooling of your rig is very important for proper operation over the long term.

    Regards


    Donation:
    ltc: Lfwau6srCdktFhziGFJGhZu9s3MT1xMSpR
    btc: 1K9ae2u9nWomMwf3zxJcnbmFfiFQ6fzgpT
  • Magneto,

    I notice that your shaders is set to 2048 in your configs. That looks more like a 7970 card, unless I'm missing something here.  I've got the same exact card you have, using 1792 for my number of shaders.

    Am I missing something?

  • For LTC (scrypt) mining, I decided to give it a shot with Magento's settings, as our rig is using identical cards (Sapphire 7750 Dual-X).  Without making any changes, it brought us from an average of 240 Kh/s to about 640 Kh/s, for a total average of 2.55 Mh/s for our rig, with no HW errors.  Brilliant!

    I think the big differences were the number of shaders and the thread concurrency.  I assume they were too small.

    Thanks Magento!

    V. Modus

  • I have 2x7950 dualX with boost and 1 sapphire overclock edition (900/1250) . 

    Most important for me is to keep the rig quiet (i sleep in the same room), so my cards are undervolted to 1025 mV (default is 1250). On this voltage the cards stable clock and best hashrate is 970/980/950 1400/1400/1350 producing 575/581/565 Kh/s on thread concurrency 22400. The rig is consuming 610 watts from wall. Cards temps are 55/62/65* C, with custom fan curve or 60/70/75* C with fans on default.
    Overclocked to 1050/1500 on 1150 mV they produce 630/630/580, but one cant sleep on such a loud sound. Temps are 65/75/80 with custom aggressive curve, power consumption is 740 watts from the wall. 

  • Thanks for the settings Magneto ! I got 3 hd7950 and now I reach 1,8Mha/s without problems on win7 .

  • edited August 2014

    What amd driver version are you guys using?
    As I posted on the post (paraphrased why are ppl leaving the pool), I mentioned my 7950 card used to easily pull mid-500's, even 600-700's sometimes, and now it starts at 350, and went down to 200-something last night.  I'm running 14.4 currently.
    The config I've been using the entire time (minus a port change awhile back to 4334 to see if that made a difference):
    Card is an AMD 7970..

    cgminer --scrypt -o stratum.give-me-coins.com:4334 -u My.Info -p MyPass --auto-fan --gpu-fan 50-100  --gpu-engine 1023 --gpu-memclock 1690 --shaders 2048 -I 13 -w 256 --thread-concurrency 8192 -g 2

    I run cgminer 3.7.2, but have also tried sgminer, which was recommended by someone, though the result remains identical (starts in the 300's, drops to the 200's).  Again, same exact everything USED to have me almsot twice as high.  In my previous post, I 'blamed' network difficulty (thought the difficulty was making it harder for my card to do it's job), but was corrected that's not the way it works, and that if my card spit out say 590Kh/s before, it should still do so now... 

Sign In or Register to comment.