3 x Sapphire 7950 Problems (w/ 5 LTC BOUNTY IF SOLVED)

edited September 2013 in Bounties

Hey everyone. I'm having trouble with my mining rig. I've been running cgminer and cgwatcher with 2 Sapphire Radeon Vapor-X HD 7950 OC using the following:


 --scrypt -o stratum.give-me-coins.com:3334 -u USER.1 -p PASSWORD --thread-concurrency 16384,16384 --gpu-engine 1100,1100 --gpu-memclock 1500,1500 --temp-target 75 -I 20,20 -w 256 

I have a 1000 watt psu so I know that the cards are being powered just fine. When I run only two cards, they run just fine and I average 1.3-1.5 MH/s. But, when I plugged in the third gpu and run cgwatcher/miner the gpus are all marked as OFF but I can see the changes in difficulty and the connections to the new pool blocks.

Any advice? I've been struggling for hours trying to figure it out. The first person to help me solve the issue correctly and get me up and running again will get 5 LTC. Thanks
«1

Comments

  • I would, but I need win7 for my bot trader and some school programs.

  • How are these cards connected? Individual or as a Crossfire Setup. To be honest I have had much difficulty with a Win8 Setup and not having Crossfire active. We did achieve a 3x7970 setup with 2 dummy plugs and only a partial crossfire.


    Things to note are how the connectors are connecting to the cards. If you are using adapters to get the 6 pin PCIe plugs that may be pulling to much power from that particular rail for your PSU. Also the motherboard might not be able to support that much power or isn't being supplied with enough power to power the cards. Are you using PCIe Risers? 
  • The cards are all connected individually, no crossfire. The cards are being detected, so no dummy plugs are needed. the mobo im using can handle the third graphics card and the 1000w psu just fine. I'm using PCIe Risers.

  • Hi,


    Are the Risers powered?

    regards,

    PB
  • some mb  you can use only a certain combination of pcie slots  what mb is it 

  • @PBRAZ The risers aren't powered... I didn't think that powered risers were necessary because all of the cards are being detected, they can all mine with the current efficiency, but I can't seem to get them to work properly. I noticed that when I mine with two cards with the batch file above, I get perfect mining. I rarely even get a single HW error. But, once I add the third gpu, I can't push the tc past 8192. I've tried swapping slots but I still can't get it to work properly.


    @ktbken if by "mb" you mean mobo, then I'm using a GIGABYTE GA-990FXA-UD3 AM3+


  • Hi,


    Try using only this:

    --scrypt -o stratum.give-me-coins.com:3334 -u USER.1 -p PASSWORD

    No worksize no nothing.... 

    Now start pushing the intensity and see if you start getting some results. Please post yuor findings.

    regards,

    PB.
  • Hi Soap,


    No news?!


  • How much ram do you have?  I've get all sorts of problems running my 4 7850's with the bare minimum of ram.

  • edited November 2013

    Ram isn't the problem.  He has 8 GB.  We use 4 GB and 8 GB on our 4 x 7950 rigs without issue.

    Most problems we have found with video cards not working are power related.  Hash rate and client problems are related to miner version, miner settings, and card drivers/settings.

    For Soap, 2 cards work just fine.  The addition of another causes the cards not to produce any hashrate.  My money is on a power problem.  Your power supply isn't putting out enough juice on the 12 volt rail.

    The power supply that you have rates its 12v rail at 960W

    Each card of yours takes 375W (2 x 150W 8 pin + 75W off mobo)

    3 cards = 1125W  - A serious under volting might get you there, but that is a big if.

    You have enough juice to turn them on, but not enough to ramp them up to 99% utilization.  This doesn't completely explain your gpus being marked off as under most circumstances the system would try to use them only to have the psu shut the whole system off due to overloading.



  • edited November 2013

    Assuming that your motherboard, Gigabyte GA-990FXA-UD3 is not as flaky as our UD5 version was, I'd focus on your setup.

    Provided that you are using the following:

    CGMiner 3.7.2
    AMD driver 13.11 Beta v9.2 - overdrive enabled, manual fan speed checked
    MSI Afterburner Beta - sync settings across all cards, force constant voltage, unlock voltage and monitoring, manual set of fan speed (most set it between 75 and 85)
    CGWatcher - any version after 1.3 (we have noticed no difference in reliability)

    This is what we use if everything you have installed matches above.

    --scrypt
    -o http://ltc.give-me-coins.com:3334 -u USER.1 -p PASSWORD
    --gpu-engine 1100 --gpu-memclock
    1500
    --shaders 1792
    --thread-concurrency 16384 -w 256
    -g 1 --lookup-gap 2 -I 20

    There is no need to set target temp as cgwatcher can be set to automatically adjusting gpu intensity to bring gpu temperature back into default operating temperatures. 

  • Hi Soap,

    I just saw this thread and have only scanned it briefly.  However, here are some things you can try.  As BBMLLC said, power may very well be the problem.  You could try running each card at intensity 13 (-I 13), which would be using less power.  I'm running 3x 7850 cards with no problem at intensity 19, but they are not as power hungry.  Here are some random other things.

    * Use cgminer 3.7.2 as BBMLLC said.  I understand that later versions have deleted gpu and scrypt support.
    * Try running each card individually, in each slot, without any alteration of the clocks or voltages.  That should verify each slot and each card and the motherboard.
    * If starting cgminer from a dos window or batch file, run each in a separate window and put only the command for one card in each window or batch file at one time.
    * Here is the command I use for each card except the one that's driving my monitors, which I run at lower intensity.

    cgminer.exe --scrypt -u USERNAME-FOR-THIS-CARD -p PASSWORD -o stratum+tcp://ltc.give-me-coins.com:3334 --gpu-platform 0 -d 2 -w 256 -v 1 -I 19 -g 1 -l 1 -T  --thread-concurrency 0

    This particular command is for the 3rd card in my system, platform 0, device 2.  Other cards would be device 1 and 0.  I run a separate command for each.  I think the -T puts cgminer in text only output mode, which GUIMiner uses.  Check that in the readme for cgminer, but you may wish to delete that for interactive mode in the dos window.

    You can use GUIMiner Scrypt to control all your cards from a point and click interface.  But, it also has a console so you can monitor the commands that are being issued.  GUIMiner triggers cgminer to do the work.

    https://bitcointalk.org/index.php?topic=150331.0

    At one point, I spent quite a bit of time tinkering with thread concurrency and going nuts.  I found that, by leaving it off in the dos window or by setting it to zero in GUIMiner, cgminer will pretty much max out the card.  So, I just let it do that and don't worry about it.

    Verify that each individual card can run at intensity 19 by itself in an individual slot.  Then, try to start combining them.  Make sure you have LOTS of airflow over these cards and that their own fans are working.  Get a way to monitor the card temperature if you don't already have it.  Mine run around 80 degrees C.  I've heard that some newer AMD cards run hotter but I don't know about the ones you mentioned.  I run GPU-Z for monitoring.

    http://www.techpowerup.com/gpuz/

    Your PC system may be generating 500 W of heat or more.  You HAVE to keep it cool.  Otherwise, the cards will throttle back.

    Hope this helps.

    Ron


  • I have the UD3.

    1. The machine won't even boot past grub (if at all) with 3 cards unless I disable certain features in the BIOS. The mobo is not designed for 3x cards. Why that hack, i mean config, works I have no idea. 4x cards never worked.
    2. I run 3 cards on a 1350 Watt PSU. You might be able to get away with 1000, but I doubt it.
    3. I might be able to suggest a mobo that doesn't need a hack like this.

    Talk to me in #give-me-coins on freenode IRC for the fix. I have to actually go through the menus to see what I did.

  • So you think a 1200 watt PSU would be the fix... I've tested the cards individually and they work fine.

  • Before buying a new power supply, you might want to measure your power usage with a Kill-A-Watt EZ.

    http://www.homedepot.com/p/P3-International-Kill-A-Watt-EZ-Meter-P4460/202196388

    Most power supplies are 80% - 90% efficient.  So, if the Kill-A-Watt EZ says you're pulling 1000 W, it's probably delivering 800W - 900W to the PC.

    You could also try running all the cards together at lower intensity for testing, which will use less power.  They should be able to run at intensity 13 or maybe less.

    If you get a new power supply, make sure it's 80+ Bronze, Silver, or Gold rated.  Each ranking increases efficiency, but 80% is the minimum.

    Ron

  • edited November 2013

    Hi SoapSuds,


    I had this problem before with one of my 7950 rigs. 

    After a lot of trial and error, it ended up being that one of the cards went bad due to not having powered risers, and because of that it also fried a slot in my mobo. Once that bad card is out of the mobo/not connected to it though your cards will most likely not have any issues once you pinpoint it down. Even if you don't see any physical damage on your board, one of your slots is probably corrupting the connection to the other cards that are on there. The recommendation is to do the following:

    1) Use powered risers for your connections
    2) Test to make sure it is the card causing the issue only while it is connecting, if you're not sure which one it is, you will need to test one at a time in different combinations until you find the faulty card. Since you only have 3 cards this should be easy since theres only 6 potential different combinations
    3) Use a different spots on your mobo to test. If you don't have an extra spot available keep in mind that you can use 1-16x risers in a 16x spot with a bit of tweaking, so a whole new mobo is not required.
    4) Once you narrow down the bad card, send it back to RMA. They usually replace it or repair it.

    Source: One of the faulty cards I removed no longer corrupted my rig after nerd raging and now works as an independant vidyagaming card instead. My mobo's are happy again.

    Hope this helps, Happy Turkey Day
    c0q

    PS. On a side note, setx GPU_MAX_ALLOC_PERCENT 100 and setx GPU_USE_SYNC_OBJECTS 1 are really critical components to have on your config file. Make sure you have those as well.

    c0q
  • Hi Soap,

    Any update to report? I was wondering if this has been solved.

    Cheers

  • Tried running the cards individually. They all work. I tried to run the cards at a lower intensity, still didn't work. I have another PSU coming today so I'll provide an update either today or tomorrow.

  • Hi there,


    This somewhat happened to me before, swapped everything, tried every possible, though not relating to bitcoin or any coin mining ( SL3 bruteforce) but I assume it was the same anyways. The problem might be like what I have experienced, as I have changed the PSU then from 1KW to 1.2 KW, still the same error, the third one when added slows every other card. I tried changing cards to HD 6990 x2, still the same, when the second one is added, both of them slows down.

    The solution I have found, after exhaustive efforts. was the motherboard. It seems the motherboard (MSI FX990A) has some bit of problems, underpowering(no other words for it) on one of its PCI-e lanes, making the x16 go like it was only x8, possibly slowing things down on three cards (6870's) and 2x 6990's. I even experienced BSOD's on windows(in an effort to see if OS was part of the problem). After RMA of the same board, lucky for me its still covered in warranty. Problem is solved.

    Though its not directly the same as our mining, same thing happens on SL3, they use card to calculate(bruteforce) hashes

    .
    Hope this might get you on an idea for your problem. 

    Correct me if im wrong, just I have had this kind of experience, and there what I have done to fix it.
  • Hello Soap, so did the new PSU work? If not, you can try running cgminer in Linux. If there's something wrong with your hardware it's much easier to find out what's wrong than in Windows. I'm a developer with 8 years of experience in Linux environments, and I can help you if you decide to try it. If you have any questions send me a PM.

  • Hi djnoel,

    It's a good thing you were able to rma your board and fix your problem.  That was a strange occurrence.

    I think it's normal for motherboards to throttle down pci-e cards from 16x to 8x or 4x when you add more cards to the board.  I have no idea how that affects mining.

    Obviously, your problem was something different since the rma fixed it and what I'm discussing is a design feature.

    Sincerely,

    Ron

  • I was able to daisy both PSUs so I know the GPUs are fully powered, but I still get this error...


    image
  • edited December 2013

    Yeah like I said before, ideally Soap can try mining with 3 cards in a 64-bit Linux. That set-up has a high probability of fixing his problem. At least it will let us know for sure if it's a hardware problem or a software problem. Soap, if you're intimidated by Linux you can also try mining in 64-bit Windows 7, I think that's enough to fix your problem. Just make sure whatever OS you choose is 64-bits.

    LTC donations welcome: LKiSjiFzVsE6bsHhJKySaQ62fT4iA3BAcB

  • edited December 2013

    What version Windows are you using? If the issue is still happening, I know -5 error is a driver problem. Avoid XP. Use 7. Try Linux.

  • I second crypt0queen's linux suggestion.

    If the 7950 is like my 6950, linux recognizes it as a single card as 2 gpus. Win 7 may be seeing issues with so many cards, and linux is generally recommended for high-card systems.  You can install it in addition to win7 (try first), or try a virtual machine installation within win7.

    Use cryptobadger's guide to install linux, with the following notes:

    http://www.cryptobadger.com/build-your-own-litecoin-mining-rig/

    Update to cgminer 3.1.0 - last to support scrypt
    Also install libjansson (sudo apt-get install libjansson libjansson-dev)
    Check Cryptobadger's FAQ for the fix for libudev.so.0

    You could also try the SMOS (Small Mining OS) linux distro on top of win7.  I haven't tried it yet, but will next week.

  • Hey Soap, 

    I know that this is probably a given but have you updated your .bat file for the third card
    ex.
    --scrypt -o stratum.give-me-coins.com:3334 -u USER.1 -p PASSWORD --thread-concurrency 16384,16384,16384 --gpu-engine 1100,1100,1100 --gpu-memclock 1500,1500,1500 --temp-target 75 -I 20,20,20 -w 256
  • edited December 2013


  • I have multiple cards running on both a win 7 64 system and a Linux Mint 13 system.  No problems on either.  I recommend running a completely separate cgminer command for each card and specifying the --gpu-platform and --device parameters to target each command to a different card.

    Also, putting the -T option on the command will allow the status and error messages to scroll downward rather than repainting on the same area of the screen, which may be more educational about the error.

    Sincerely,

    Ron

  • Absolute next thing you should do is update cgminer to 3.7.2.  There are a lot of hardware related fixes since 3.3.4.  Most threads related to this issue just sort of disappear without resolution so I'm betting it's not that complex of an issue.


    Poofy
  • You can either do 3 things for the enque command errors

    1. Get more memory because you will get that error if you set your thread concurrency too high for the amount of system ram you have.

    2. Lower thread concurrency for the amount of system ram you have currently. 
    3. Disable antivirus because it probably deleted some of your files
  • edited December 2013

    I do not think your motherboard supports 3x video cards. 


    "Flexible graphics capabilities - Up to 2 VGA cards are supported for either 2 way CrossFireX™ or 2 way SLI™ action, delivering the ultimate in graphics performance for gaming enthusiasts who demand the highest frame rates without compromising on resolution.


    "Note: Please update the latest version of BIOS from GIGABYTE website and VGA driver from vender’s website.."


    "(Note 3) For optimum performance, if only one PCI Express graphics card is to be installed, be sure to install it in the PCIEX16_1 slot; if you are installing two PCI Express graphics cards, it is recommended that you install them in the PCIEX16_1 and PCIEX16_2 slots."


    Have you tried to update your MB bios? might work if they have changed something.


    LXJU7WwHLhjQZt7gwAMyQVdpvCzLWK7AeE
  • His motherboard supports 4 video cards - the "problem" is that there's only two 16x slots (xfire and SLI compatible) and two 4x slots (not xfire or SLI compatible).


    SoapSuds, because you're not running xfire at all, populate both 4x slots and see if that works with cgminer (should work with no problem).  Then put the 3rd card in the first 16x slot (since the second 16x slot will be blocked anyways).  This should work.  Because you're populating both 16x slots and then using a single 4x slot your machine is likely thinking that you're trying to xfire the 16x cards and use the 4x off to the side.  It then notices you don't have the bridge installed and glitches-out.  By using both 4x slots (not xfire compatible) and only one 16x slot (xfire compatible but not possible due to the empty second 16x slot) there should be no issues from a configuration/driver standpoint.

    Let us know how this works out.
  • Hi Soap,


    I had the exact same problem with my 3x 280x rig. Solved it by adding the following to the top of the .bat file:

    setx GPU_MAX_ALLOC_PERCENT 100
    setx GPU_USE_SYNC_OBJECTS 1

    Good luck,
    Amin
  • Please explain how exactly you daisy'd these power supplies. You can't just plug them in back to back and get more power to your system. Everything is Transformed at the PSU plugged into the system components and only supplies what it is rated for to the system.

    That being said this is a power issue in my opinion.

    You've got 3x 7950 that will draw around 180-190W while mining. Lets rough that at 600W

    A 1000W will be rated at about 80% efficiency(slightly more for top tier supplies). This leaves you essentially 800W useable.

    This leaves roughly 200-250W for all your other system components to share(CPU, RAM, MOBO, HDD, DVD, any other trinkets like USB mouse and keyboard ect.). This is not a lot of power to go around.

    Something to note. Pushing a power supply to it's limit will reduce efficiency lower than 80%. Also, a PSU at it's limit will tend to supply more unstable voltage than when it doesn't have to work as hard.

    All this leads me to believe that power requirements along with unstable voltage delivery are what's causing you problems with this 3rd card.

    Upgrade to 1200W or more and you will likely clear things up.

    As an aside I encountered a similar issue setting up my bosses Bitcoin miner over 2 years ago with 3 6970's. 1000W wouldn't cut it and when I upgraded to 1250W no problems anymore

    Donations accepted:

    LY5D6KM9Su1hnDDAKJRZv4fcXm2FjHrQQW

  • edited December 2013

    Sorry I couldn't get back to you guys in a while. I had finals... SO MUCH STRESS. Anyways. I'm just going to address a couple of points/questions people made.

    @Lannister, The PSU's are daisy chained using an Add2PSU component, a known and easy way to add more power without shelling out the cash for a new psu. http://www.add2psu.com/

    @aminland, I have the setx commands in. Still no luck.

    @dakwah, I have plenty of RAM 8gb is fine.

    @granorismo, yup, I have the command in place for a third gpu, not just 2.

    What I'm going to do this week:
    1. I'm currently upgrading the rig case... so everything is getting gutted and being placed in a nice aluminum body (will post pics later).

    1. Upgrading to a 64 bit OS (Win7), can't use Linux as I run EasyMiner for my BFLs and I use a bot trader that only runs on Windows.

    2. I should be getting my powered risers by the 30th according to my tracking, so I'll attempt that along with @dfalcon413 's suggestion.

    3. Upgrade CGMiner

    If I'm missing anything, please comment. While I'm on break, I'm pretty much spending my whole time trying to fix these GPUs and to rebuild the case.

    Thanks,

    SoapSuds

  • Hey


    I had the same problem the solution was to remove the bin files in the CGminer directory AND put in a better brand of memory.

    I built a rig with a cheap motherboard, processor and memory. Turns out if you want to run 5 cards (I have 5 x 280x's running and one rig with one 290x with 3 more on the way), memory might become important. I know you're not running 5 cards. But maybe..:)
  • just some thoughts, trying to cover things that others havent covered....

    -turn off crossfire
    -goto bios and turn off PCIE spread spectrum, and any other weird options for pcie (overclocking etc)

    -download multiminer, it comes with BFGminer, and should work on the hardware out of the install. if it does, then your CGminer needs an update or configuration settings. (alot of the settings are the same).

    i couldnt get cgminer to work good with my (3) x r9 290's and im runnning them great on bfgminer.....at 2.4 Mh/sec
    my cards are all watercooled.

    so get a baseline on bfgminer, and verify your hardware stability.

    once u know its good, then go on to troubleshoot why cgminer isnt working, update it and read the config files for tuning etc.


    hope it works for you :-)

  • Soap add the third GPU. Go into your cgminer directory and delete the config file that is generated by the miner. Now run your bat file with your third gpu settings set. Have seen it where Cgminer will "hold on to" a config setting which corrupts your run. What version of CCC do you have installed.

    Also take the intensity of your gpu running your screen down to 13 just to test.

  • edited January 2014

    Have you run setx GPU_MAX_ALLOC_PERCENT 100 and setx GPU_USE_SYNC_OBJECTS 1 from cmd?  Also you can try adding -d 0,1,2 to your cgminer command or in cgwatcher set the device value to 0,1,2

  • Not sure with full voltage and speed on the three cards, but at standard clocks you should be able to run them with your psu, and anyway you say you got two psu's chained so that is not the problem.

    From experience on some card shuffling I did in the past with many gpu's and pc's (I mine with two more friends hatdware and tested it on different setups):

    Usually you should try to get a somewhat high (finetuned) concurrency and intensity, which would use X card's vram and Y main system ram... However, sometimes a combination of hardware and/or software specs fails when trying to allocate resources even if you have enough ram, vram and setx commands rightly done.

    What you do in those cases if you can't find a solution is forcing cgminer to use a lower concurrency with a lower intensity and two threads per gpu. Sometimes it still reaches optimal hashrate although the usual is lossing some hashrate in the end, but at least it works.

    for example, if you do -tc 16384 -I 20 you could try -tc 8192 -I 20 -g 2
    g being the threads per gpu, default is 1
    for reference, with low tc gpu's use to give hw errors above intensity 13 so you could have to go with that instead of intensity 20 but -g 2 should compnsate it.

    If you can, use msi afterburner, the last beta, even if you don't overclock, as you can enable a monitoring of vram, system ram and pagefile usage while testing the variances I explained above and you will see better how it works.

    ps. If you are using the same exact clock or whatever parameters on all the cards you can put them once in cgminer and they will have effect on all the gpu's, no need to comma-duplicate them.

    Tldr, lower tc and intensity, double threadpergpu
    Good luck!

  • Ah, I have the same mobo, great mobo too.  Ive got 4 gpus on that board.  Lets start with the basics.  Update dat mobo bios. Plug in all 3 cards, uninstall drivers, reinstall 13.11 drivers.  Make sure there are no errors when the install is complete.  Delete all the .bin files in CGMiner.  Run your setx commands, run a basic .bat file eg. cgminer.exe --scrypt -o stratum.give-me-coins.com:3334 -O user.work:pass   If the basic commands don't work then somethings up.  Try updating the gpu bios.  Is your psu single rail or multirail?  Maybe your overloading a rail.  

  • Hi all,

    I posted some info up above that I wish to modify.  Before, I recommended running a separate instance of cgminer for each card.  I have now changed my position on that.  When I was doing that, and using auto fan and gpu engine control, I had problems.  The fans on the multiple cards would get to where they were oscillating between 0 and 100% rather than maintaining a constant speed to keep the temp at the set point.  The gpu engine speeds would gravitate to the lowest speed of any of the cards rather than having individual settings.  I have documented my new procedures in the thread below if you're interested.  Once I went to having one cgminer control all cards, the problems went away.

    https://forum.give-me-coins.com/discussion/666/heat-death-how-to-kill-your-gpu-in-less-than-a-year#Item_4

    Sincerely,

    Ron

  • In trying to solve this (possibly unsolvable) problem you seem to have gathered some extra parts.  Just buy a cheap, non-Gigabyte FM1|2 mobo + APU and KVM switch (optional) then run it as an 'open-air' system using the parts you've tried to shoe-horn onto the Gigabyte mobo using a usb 2 flash (or any spare HDD) to boot an OS.  The sooner you bite the bullet and get that third card running, the larger its ROI will be.  Do yourself a favor though; download and read the manual of any hardware before purchasing it.

  • This problem is months-old, so I suppose it's been solved for a long time ? 


    Soap writes "Upgrading to a 64 bit OS (Win7)" : was he using windows 7 32 bits ???

    Every tutorial out there states that one should use a 64 bits OS. The problem might come from this. Anyway it's foolish to build a mining rig and not use a 64 bits OS.
  • HI Soap,, just saw this prob and thought I would ask if you have tried forcing a change of ports?  win7 is supposed to do all that automatically but sometimes the addresses will conflict with similar/like devices. 
    anyway,, good luck and I hope you find the solution soon.

    late

  • if you are running other miners there may be a CPU starvation problem as well.

    start your cgminer first, then the other miners.

    if it crashes then, you can give cgminer more CPU priority before starting the other miners.
    Yes, none of these are CPU bound, but priority affects how quickly the OS services requests.

    is one of these cards your primary display? Windows can get confused. Use the built-in card for your display.

    also try sgminer instead of cgminer.

    good luck.
  • I read the first several comments, but did not see a post throughout, so I'll ask.

    What happens if/when you run cgminer -d (with your same settings as above) and have three separate instances.  I had an issue initially with cgminer on one host running cgminer with 3 r9 270x - i ended up running them individually

    cgminer -d 0 blah
    cgminer -d 1 blah
    cgminer -d 2 blah

    and had three separate mining windows open. worked much better, you'll need to adjust the api port between each instance - but not terrible.  Running sgminer, I was able to keep all 3 in one mining instance.

    Just sharing...

Sign In or Register to comment.