Vertcoin Hard Fork at block 347000

New vertcoin hard fork programmed for block 347000.

Mining software update will be required.



Tagged:

Comments

  • Great!


    Will it be possible to switch the port manually at block 347 000 this time so we can take advantage of the low diff just after the fork?

    Last time the port was meant to be switched automatically but if failed for some reason and we had to wait a couple of hours for it to become available which is crucial in this case.

    Thanks.
  • Hello.


    I'll have to create some scripts to do that, but it's possible. I'll keep everyone posted.

  • Thanks.


    So when the fork happens at block 347 000 we will continue mining at vtc-l2.give-me-coins.com:3337?

    Also, can we have a Lyra2REv2 test port so we can test our miners before the fork?

    Regards.
  • Hello.


    New server will be at: vtc.give-me-coins.com:3337
    Testing is now possible.

    I'm working on making it automatically change upon fork.

    Old servers will be turned off upon fork.

    Cheers.

  • edited August 2015
    Great!

    Can we sleep well assured that vtc.give-me-coins.com:3337 will automatically and seamlessly switch from testnet to mainnet at block 347000? There was some kind of a problem with auto running the server at the last fork in December.


    Cheers.
  • Hello.


    Yes, you can :)
  • Change to new algo processed as expected, without downtime or wasted shares.

    Also, we have already found a block with the new algo.

    Cheers.

  • Mining in process, but in dashboard zero kh/s. Something I have to update?

  • @Wanderer: check your miner window. Any error? Have you updated to latest mining software with lyra2 v2 ?

  • @khaos, congrats for the flawless execution :)>-

  • edited August 2015

    @khaos Haven't error, but have much "Rejected". Began at the morning today. Programm sgminer-v5-Lyra2RE-RC1-WIN32 (Latest). At clear .conf file got the same result.
    image

  • New miner 5.1.2-lyra2rev2. Kernel Lyra2REv2. About 50% rejected (high-hash) on vtc.give-me-coins.com:3337 with any settings I tried. On verters.com mining looks fine (less than 1% rejected) with old settings. Any suggestions?

  • @Wanderer / @Mieszko


    Add
    --difficulty-multiplier 2
    in your .bat file

    OR

    "difficulty-multiplier" : "2"
    if you use conf file.

    Cheers.
  • Thanks. It seems to be working now with --difficulty-multiplier 2

  • @wanderer Did you update your miner?


  • edited August 2015

    @Wanderer: If you are using the latest version, I have no idea. High hash usually means error on the configuration/miner software.

    Have you tried starting with a bare minimum configuration only to confirm it works before optimizing the configuration?


  • @khaos Yes, I've tried again, with build 5.1.1-lyra2rev2 from github.com, with clear .conf (on the screenshot) . =(

    image
  • @wanderer: I have no more ideas :( 

  • I got the same problem here.

    Any conf gets R:100% high-hash, even with clear config file. 
  • I've found only one good topic with the same problem, but I can't understand, how they fixed it https://github.com/slush0/stratum-mining-proxy/issues/35

  • @bebop @wanderer Are you both using stratum-mining-proxy? If yes, does it work when you connect directly to the pool?



  • edited August 2015

    @khaos I don't know, I did all by instructions "getting started" http://give-me-coins.com/support/lyra2re-guide/

  • Have cheked the same config on other pool. All is working fine.

  • @bebop @wanderer Could it be the difficulty-multiplier problem? What value are you using?

  • Use VertCoin miner  https://pool.verters.com/index.php?page=gettingstarted

    Add
    --difficulty-multiplier 2
    in your .bat file

    Add
     --kernel Lyra2REv2    instead   --kernel Lyra2RE
    in your .bat file


  • Finally I`v done it.

    I did change "--kernel Lyra2REv2    instead   --kernel Lyra2RE" and it works.

    Is there are some new statistic for a new speed of mining?
  • @5ABC @bebop It is necessary to use run.bat? How i can make it, if I use .conf?

  • Hi, I have the same problem of high hash rate. Can someone help me? This is my bat file:

    sgminer.exe --kernel lyra2rev2 -o stratum+tcp://vtc.give-me-coins.com:3337 -u djask.vtc -p x --difficulty-multiplier 2 --intensity 15 
  • hi, i tried again, and corrected the kernel, and now it just hangs on "initialising kernel". 

  • I do use conf file like this:

    {
    "pools" : [
    {
    "url" : "vtc.give-me-coins.com:3337",
    "user" : "bebop.02",
    "pass" : "password"
    }
    ]
    ,
    "intensity" : "16",
    "difficulty-multiplier" : "2",
    "worksize" : "64",
    "kernel" : "Lyra2REv2",
    "algorithm" : "Lyra2REv2",
    "lookup-gap" : "2",
    "gpu-threads" : "2",
    "gpu-memclock" : "0",
    "gpu-powertune" : "0",
    "temp-cutoff" : "95",
    "temp-overheat" : "85",
    "temp-target" : "60",
    "api-mcast-port" : "4028",
    "api-port" : "4028",
    "expiry" : "28",
    "failover-switch-delay" : "60",
    "gpu-dyninterval" : "7",
    "gpu-platform" : "0",
    "log" : "20",
    "no-pool-disable" : true,
    "queue" : "1",
    "scan-time" : "7",
    "tcp-keepalive" : "30",
    "temp-hysteresis" : "3",
    "shares" : "0",
    "kernel-path" : "/usr/local/bin",
    "verbose" : "true"
    }

  • edited August 2015

    And bat file like this:


    setx GPU_MAX_ALLOC_PERCENT 100
    setx GPU_USE_SYNC_OBJECTS 1 
    sgminer --config sgminer.conf
  • Used a Bebop's config, and now i have an error "initialising kernel",like Djask 

    image
  • Hey guys, I seem to have fixed my problem. Here is my conf file if anyone's interetsed. 

    {
      "pools": [
        {
          "url": "stratum+tcp://vtc.give-me-coins.com:3337",
          "user": "djask.vtc",
          "pass": "x"
        }
      ],
      "profiles": [],
      "difficulty-multiplier": "2",
      "failover-only": true,
      "algorithm": "Lyra2REv2",
      "device": "all",
      "intensity": "18",
      "xintensity": "32",
      "worksize": "32",
      "gpu-threads": "4",
      "thread-concurrency" : "8192",
      "temp-cutoff": "95",
      "temp-overheat": "85",
      "temp-target": "75",
      "gpu-memdiff": "0",
      "shares": "0",
      "kernel-path": "/usr/local/bin",
      "api-mcast-port": "4028",
      "api-port": "4028",
      "expiry": "28",
      "failover-switch-delay": "60",
      "gpu-dyninterval": "7",
      "gpu-platform": "-1",
      "hamsi-expand-big": "4",
      "keccak-unroll": "0",
      "log": "5",
      "no-pool-disable": true,
      "no-client-reconnect": true,
      "no-submit-stale": true,
      "queue": "1",
      "scan-time": "7",
      "tcp-keepalive": "30",
      "temp-hysteresis": "3",
      "watchpool-refresh": "30"
    }
  • @djask ;
    I've tried, "initialising kernel" again =(

  • Anyone willing to post their working conf file for 280x. I have not been able to get any settings to work.

    Thanks
  • Someone else solved this problem?

  • I've changed my config again, so now I'm using a batch file. Try this: 

    setx GPU_MAX_HEAP_SIZE 100
    setx GPU_USE_SYNC_OBJECTS 1
    setx GPU_MAX_ALLOC_PERCENT 100

    sgminer.exe --kernel Lyra2REv2 -o stratum+tcp://vtc.give-me-coins.com:3337 -u djask.vtc -p x -g 8 -w 32 -I 15 --difficulty-multiplier 2
  • edited September 2015
    Hi, I've downloaded the sgminer and ccminer binaries from vertcoin.org, but not having much luck on either my GTX680 or Radeon R7 260X GPU's.
    I've tried a few different settings, but even default settings don't appear to work.
    On the GTX card, only 15% of GPU seems to get used, the intensity setting just seems to alter the memory usage. I get a few figures now and again, but mainly 0.0 hashes For example:

    ccminer -a lyra2v2 -d gtx680 -o stratum+tcp://vtc.give-me-coins.com:3337 -u name.worker -p P xxxxx

    [2015-09-10 20:18:35] Starting Stratum on stratum+tcp://vtc.give-me-coins.com:3337
    [2015-09-10 20:18:35] NVAPI GPU monitoring enabled.
    [2015-09-10 20:18:35] 1 miner thread started, using 'lyra2v2' algorithm.
    [2015-09-10 20:18:35] Binding thread 0 to cpu 0 (mask 1)
    [2015-09-10 20:18:36] Stratum difficulty set to 0.125002
    [2015-09-10 20:18:37] GPU #0: GeForce GTX 680, 5273694
    [2015-09-10 20:18:37] GPU #0: GeForce GTX 680, 6393571
    [2015-09-10 20:18:38] GPU #0: GeForce GTX 680, 0.00
    [2015-09-10 20:18:39] GPU #0: GeForce GTX 680, 0.00
    [2015-09-10 20:18:40] GPU #0: GeForce GTX 680, 0.00

    On sgminer, even the lowest intensity setting of 8 is giving me invalid nonces
    sgminer --kernel Lyra2REv2 -o stratum+tcp://vtc.give-me-coins.com:3337 -u name.worker -p xxxxx --difficulty-multiplier 2 --gpu-platform 1 --verbose

    [20:21:54] (5s):69.01K (avg):110.4Kh/s | A:0  R:0  HW:0  WU:0.000/m
    [20:21:59] [THR0] GPU0: invalid nonce - HW error
    [20:21:59] (5s):85.14K (avg):110.5Kh/s | A:0  R:0  HW:1  WU:0.000/m

    Any Ideas?
  • With ccminer under ubuntu linux 15.04 updated and a GTX650.

    ./ccminer -a lyra2v2 -d gtx650 -o stratum+tcp://vtc.give-me-coins.com:3337 -u myuser -p xxx -X11
    *** ccminer 1.5.62-git(SP-MOD) for nVidia GPUs by sp-hash@github ***
    Built with the nVidia CUDA SDK 6.5

      Based on pooler cpuminer 2.3.2 and the tpruvot@github fork
       CUDA support by Christian Buchner, Christian H. and DJM34
      Includes optimizations implemented by sp , klaust, tpruvot and tsiv. 

    [2015-09-12 01:34:38] tid(0x00004a7a) XIntensity set to 11, 720896 cuda threads
    [2015-09-12 01:34:38] tid(0x00004a7d) Starting Stratum on stratum+tcp://vtc.give-me-coins.com:3337
    [2015-09-12 01:34:38] tid(0x00004a7a) NVML GPU monitoring enabled.
    [2015-09-12 01:34:38] tid(0x00004a7a) 1 miner thread started, using 'lyra2v2' algorithm.
    [2015-09-12 01:34:38] tid(0x00004a7f) Binding thread 0 to cpu 0 (mask 1)
    [2015-09-12 01:34:38] tid(0x00004a7d) Stratum difficulty set to 0.125002
    [2015-09-12 01:34:39] tid(0x00004a7d) Stratum difficulty set to 0.125
    [2015-09-12 01:34:39] tid(0x00004a7f) GPU #0: GeForce GTX 650, 14532721 Temp= 40C Fan= 48%
    [2015-09-12 01:34:40] tid(0x00004a7f) GPU #0: GeForce GTX 650, 17349699 Temp= 40C Fan= 48%
    [2015-09-12 01:34:40] tid(0x00004a7f) GPU #0: GeForce GTX 650, 578 Temp= 39C Fan= 48%
    [2015-09-12 01:34:40] tid(0x00004a7f) GPU #0: GeForce GTX 650, 540 Temp= 40C Fan= 48%
    [2015-09-12 01:34:40] tid(0x00004a7f) GPU #0: GeForce GTX 650, 560 Temp= 40C Fan= 49%
    [2015-09-12 01:34:41] tid(0x00004a7f) GPU #0: GeForce GTX 650, 526 Temp= 40C Fan= 49%
    [2015-09-12 01:34:41] tid(0x00004a7f) GPU #0: GeForce GTX 650, 21348069 Temp= 39C Fan= 49%
    [2015-09-12 01:34:41] tid(0x00004a7f) GPU #0: GeForce GTX 650, 577 Temp= 40C Fan= 49%
    [2015-09-12 01:34:41] tid(0x00004a7f) GPU #0: GeForce GTX 650, 541 Temp= 40C Fan= 49%
    [2015-09-12 01:34:42] tid(0x00004a7f) GPU #0: GeForce GTX 650, 557 Temp= 40C Fan= 49%
    [2015-09-12 01:34:42] tid(0x00004a7f) GPU #0: GeForce GTX 650, 509 Temp= 40C Fan= 49%


    Any suggestion?
  • Hi! Maybe, someone find a new solution for this problem?

Sign In or Register to comment.