Please Help with Vertcoin Setup

edited June 2014 in Vertcoin

Hello, I have been mining LTC without a problem for some time. I want to put some of my miners on VTC.


On this particular setup, I have an NVIDIA GeForce  (not mining) as my main, and a Sapphire HD7950 for mining. My .bat file is the following:

setx GPU_USE_SYNC_OBJECTS 1 
setx GPU_MAX_ALLOC_PERCENT 100

vertminer --scrypt-vert -o stratum+tcp://vtc.give-me-coins:3337 -u user -p pass --gpu-platform 0 -d 0 -w 256 -v 1 -I 20 -g 1 -l 1 -T --thread-concurrency 21712


I have also removed the config file from the directory.

The error I get is "Failed  to resolve (Wrong URL)"....but clearly the URL is correct. I have tried without stratum+tcp://, with http:// and nothing...the strange thing is that if I use my .conf file, then it works fine, but I don't know the syntax for the --gpu-platform and -d commands so vertminer will only tell my 7950 to mine.

Any thoughts?


Comments

  • Let's see your conf file.

  • Also try --nscrypt instead of --scrypt-vert 


  • {
    "pools" : [
    {
    "user" : "user",
    "pass" : "pass"
    }
    ]
    ,
    "intensity" : "12",
    "worksize" : "256",
    "lookup-gap" : "2",
    "gpu-threads" : "1",
    "expiry" : "30",
    "scan-time" : "5"
    "gpu-platform" : "1"
    "disable" : "0"
    }

    I did not modify any of the settings except for adding the last two in order to ensure the 7950 is being used for mining. Again, when I load vertminer normally (not with the .bat file), it gives me a fatal JSON error in the conf file. I am going to try deleting the directory and extracting vertminer again from scratch...for the 3rd time.
  • So, vertminer works fine with the default settings, but obviously it is mining from the primary (the NVDIA) in this case. All I need to know is the syntax for the commands to tell vertminer which gpu to mine on. I have this working fine for mining LTC with cgminer, but I am using a .bat file there and the syntax is different.

  • Okay, I got it to work with the .bat file up there...I needed gpu-platform set at 1, not 0. Now, the issue is I am mining at 130kh/s when I should be around 275kh/s...I will continue looking for the ideal conf for the Sapphire HD 7950...any input will be very much appreciated. Thank you.

  • At this point I am hashing at 150kh/s with the following:


    .bat file:

    setx GPU_USE_SYNC_OBJECTS 1 
    setx GPU_MAX_ALLOC_PERCENT 100

    vertminer --scrypt-vert -o stratum+tcp://vtc.give-me-coins:3337 -u user -p pass --gpu-platform 1 -d 0 -w 256 -I 13 --thread-concurrency 8192

    conf file:

    {
    "pools" : [
    {
    "url" : "stratum+tcp://vtc.give-me-coins.com:3337",
    "user" : "user",
    "pass" : "pass"
    }
    ]
    ,
    "intensity" : "13",
    "worksize" : "256",
    "lookup-gap" : "0"

    }


  • Any tips on getting that extra 100kh/s?

  • Okay...I just had to set -I 20...so much for taking people's word online ;)...feel free to delete this thread.

Sign In or Register to comment.