Disable / Turn Off GPU (Device) via SGMiner BAT or CONF file...

edited June 2014 in Miner Configs

Hey folks,


Was wondering if someone could please help me with this, as for whatever reason I'm just having a really dumb moment here! Either that, or it just can't be done!?  :S

I have two rigs, both of which have as their primary cards (i.e. GPU 0 / Device 0) cards that I cannot mine on or do not want to mine on. So, how do I tell SGMiner to skip initialising these cards at startup? I understand you can do this from within SGMiner using the [G] menu, however, by the time I can get to there, SGMiner has already realised it can't do anything with GPU 0 and SGMiner has already disabled it! While this is fine if I am starting SGMiner manually, if I want SGMiner to start automatically, it will hang because during startup, SGMiner tries to initialise GPU 0, realises it cannot, then wants someone to hit the enter key so that SGMiner can continue.

So yes, I would like to know how I can achieve disabling / turning off / excluding this GPU 0 from being seen or initialised by SGMiner via my BAT file or my CONF file.

If someone can help, that would be tops  :)

Thanks folks.

Kind regards,
Dodgy Bob

Comments

  • edited June 2014

    Well, after a good nights sleep and coming back to things, I thought about what I was doing last night and first up I just tried switching the 'd' option in my CONF file from 1 to 0 - I remember having come across in CGMiner that the device numbering was back-to-front in it, so thought perhaps that that was what was going on here in SGMiner ... turns out no it wasn't!


    But that led me to go back to square one and use the KISS principle: Keep It Simple, Stoopid!

    So having reverted the 'd' option back to 1 - because it is Device.1 I want working and not Device.0 - I added the option 'remove-disabled' ... and that was it! That was all I needed. So in my CONF file I now have after my 'd' option, this...

    "remove-disabled" : true,

    ...and everything is working like I wanted it to. SGMiner doesn't prompt me to hit enter to continue, it just does what its told and off it goes! Fantastic  :)

    Not sure if other folks will want to know or need to know about this, but there you go, thats what worked for me and its all good. Perhaps because my Device.0 is a card that cannot mine, is why I was getting what I was and if Device.0 had been a card that could mine, then I would never have received the error output that I did? Oh, well, I was and now its gone!

    Have fun folks.

    Kind regards,
    Dodgy Bob
  • The remove-disabled option is needed to prevent cgminer (and clones) from controlling the other devices fans/frequencies. Not having such option can lead to weird behaviour when you run multiple cgminer instances - like fans stopping completely and then ruching at full speed and stopping again.

    Though "If I were you" - I'd simply lower the intensity for main display device - this works unless you use HW video decoding and such.

  • You saved my life mate :)

    Thanks for posting !

Sign In or Register to comment.