I am stuck on this step to mine vertcoin. SOLVED

edited March 2014 in Vertcoin

I am very new at using Linux and I cant seem to be able to figure out how to accomplish this step

From https://vertcoin.org/gpu-miner-build-howto.html:

"The installer for the APP_SDK seems to break some files, or at least it did during testing. Do the following to fix it:

cd /etc/OpenCL/vendors/

in here are two files amdocl32.icd and amdocl64.icd, you will find their contents (they are just text files) to be "files amdocl32.icd and amdocl64.icd" respectively. Edit them to include their full paths, so the contents of amdocl32.icd becomes "files amdocl32.icd and amdocl64.icd" (not including the quotation marks) and the contents of amdocl64.icd becomes "/usr/lib/fglrx/libamdocl64.so" (not including the quotation marks). These locations are valid for Ubuntu 12.04 LTS, on other distros you will need to find the .so files and put the appropriate paths into the .icd files."


I can't seem to find files amdocl32.icd and amdocl64.icd. I am using Ubuntu 12.04 LTS. I did find files amdocl32.so and amdocl64.so and there contents looks like this: ELF

When I do find those files do I just re-label the file name to files amdocl32.icd and amdocl64.icd or do I open it and erase the contents and replace with something?

I am very excited to mine Vertcoin and I am going on 3hrs of sleep so I am sure this is simple to the the rest of you miners but I just am not having any luck figuring it out on my own.

Thank you!

Comments

  • I solved my own problem; if you are having the same issue just respond to this post and I will explain further.

  • So what did you end up doing?

  • Yes please let us know, I can only imagine the frustration if I found this thread on Google with no details of how to fix the issue! :P

  • The method that finally worked for me was as follows:

    1- open home folder (not dash home)
    2- in the top right hand corner there is a magnifying glass symbol that allows a search of your files; open the search window.
    3- enter the file name: amdocl64.icd or amdocl32.icd and click the search icon at the right
    4- after step 3 it may have worked for you but I still had to go a few more steps.
    5- in the search results window there are options to either search location or file type; choose file type.
    6- next to the file type there is a drop down list that allows you to choose what type of file to search for; select text file.
    7-
    in the upper right hand side there is a button labelled reload; click reload and it will begin the search.
    8- this is how I finally found the files amdocl64.icd and amdocl32.icd
    9- open the files with text editor and delete what is in there and copy and paste /usr/lib/fglrx/libamdocl64.so (see instructions in the OP)

  • edited March 2014

    If this helped please consider a donation:

    VTC: Vj8QH1SGsFDRB58UWRanrgYMuxTpQRCybx
    LTC:  LLtNG6PaBj9MXXiPpQkvkfsniucikkNx8R
    FTC: 6gzcXtfk1oF1GYRbyp7133i7BHqHJdMtkc

    Thank You!


Sign In or Register to comment.